Managed Backup Failing at 21% Every Time

I had accidentally deleted my website over a week ago. I thought that I'd been backing it up to Updraft Plus, along with Snapshot but I lost everything.
I have tried to get my managed Backups to work but I was unable to. And I 've just rebuilt the site again over the last three days. I need to make sure that it's backing up somewhere. I need help in determining why nothing is backing up. When I get to 21% the backup stops on its own. I've tried four times in a row.

  • Ken Kimbrell

    Hello T. Webb -

    Depending on the size of your site, some variables can come into play as to why you are unable to get a full-backup of your site. After assessing your php.ini configuration it appears you have the server configured for a site that uses a lot of memory. Your max_execution_time is set to 300. Which is good, and far above the normal 30-180 seconds default configurations. It is still a possibility that the server could be timing out, however with your configuration, those possibilities become less likely.

    Have you tried decreasing the chunk sizes of the data and seeing if that prevents the backup from hanging? Try adding this configuration to your wp-config.php file. See code below:

    /***Decrease ChuckSize for Snapshot ***/
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10); //default is (250);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100); //(default is 1000);

    Also your WP_MEMORY is set to 512M but if you are backing up a site larger than that, you may want to consider configuring your php.ini more like this:

    upload_max_filesize = 1000M
    post_max_size = 2000M
    memory_limit = 3000M
    file_uploads = On
    max_execution_time = 0

    Additionally you could add to your wp-config.php file:

    define('WP_MEMORY_LIMIT', '3000M');

    In some cases it may even be a permissions problem, so you may also want to be sure to define your FTP credentials in your wp-config.php file, see configuration below:

    define('FTP_USER', 'username');
    define('FTP_PASS', 'password');
    define('FTP_HOST', 'ftp.example.org');
    define('FTP_SSL', false);

    If the problem still persists, then please provide your most recent debug.log for us to assess and determine what could be the problem.

    Let me know how I can help!

    Take Care,

    Ken - WPMU DEV Support

  • T. Webb

    Hi Ken,

    I read what you wrote and all of it is Greek to me. I don't know anything about decreasing "chunk" sizes or configuring php files. I did just now activate the debug log and I tried to backup again. It still shut down from backing up once it got to 21% backup. it sounds as though if I'm expected to know all of this type of processes that I probably should not be using this platform.

    I'm not sure where to add this info once I get into my wp-config .php file.... On a side note, I do recall seeing some verbiage stating that the server was timing out at several different points before the backups stopped. Thank you for your time.

  • Ken Kimbrell

    T. Webb -

    I do apologize for the Greek writing :slight_smile: I was able to access the chat transcript but the information provided for additional login credentials, such as FTP and cpanel seem not to be correct or perhaps was revoked.

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Ken Kimbrell"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)
    ------

    Take Care,

    Ken - WPMU DEV Support

  • Ken Kimbrell

    Hello @twebb35-

    I emailed you from our email service because of the sensitive information I was trying to acquire. My team and I have not been able to access your cpanel. The image I showed you in the email, was how the cpanel appears on our end. I am unable to gain access to the file manager. If you could send me an email of your FTP credentials we can look into this further for you. The FTP credentials you provided are not allowing us to login. I do apologize for the inconvenience. If you like, I can also walk you through the process of the configurations that I recommend you modify in hopes of rectifying the issue of not being able to do a full backup of your site.

    Let me know how I can help!

    Take Care,

    Ken - WPMU DEV Support

  • Ken Kimbrell

    Hello @twebb35-

    I had only one person on our staff able to access your file manager. Still not sure why most of us can't. He noticed that your WP_MEMORY_LIMIT was set to 40Mb, we went ahead and increased your memory limit. However, when I was going to try and test the backup I noticed I could no longer login with the credentials provided. Could you please run a test backup and see if increasing the memory had any impact on preventing the backup from hanging? Additionally if you do not mind re-granting access so we can access to the site again, that would be greatly appreciated :slight_smile:

    I hope this helps!

    Take Care,

    Ken - WPMU DEV Support

    • T. Webb

      Hello Ken,

      I've tried three times, from 6:30pm until 10pm to make a Snapshot Backup and each time they only went so far before cancelling out. Very Frustrating. I received various error messages:Gateway Timeout (Cloudflare nginx), other type of backup error and general error...

      I wound up changing my passwords because I had entered them in this message box format (which I found out was not secure) and I had so many IP's trying to sign into my account. If you send me the secure message box directly to your address I will be happy to resend my updated info. I will also regrant access to my account.

      Thank you still.

      Sincerely,
      Trudye

  • Ken Kimbrell

    Hello Trudye-

    I was able to get it to 40% but then I was kicked for being too idle. The backup just by my calculations and the time it took to get to 1%-2% would estimate that this backup could take anywhere from 90minutes to 120minutes to fully backup your site. I am a bit bummed I timed out, but our support access will do that after remaining idle for too long as a security precaution. Is there a way you could resend your new credentials by accessing our private form below:

    https://premium.wpmudev.org/contact/#i-have-a-different-question
    Please visit our private Contact page and complete the form with the following information:

    Subject: "Attn: Ken Kimbrell"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)
    ------

    Thanks and I appreciate your patience :slight_smile:

    Ken - WPMU DEV Support

  • Ken Kimbrell

    Hello Trudye-

    A little update here, I was able to get a full backup to run without fail, but I had to do a global file exclusion. I did this for troubleshooting purposes. I excluded the wp-content directory and the managed backup went through no problem at all. However that is not very useful for you to exclude such a viable directory. So I have been trying to narrow down the options, due to the size of your site that has made it time consuming. I do appreciate your patience regarding the issue. My recommendations is to continue where I left off until you find what is causing the backup to throw the error. I have tried excluding plugins and uploads directory and it still throws an error. So that leaves a few other sub-directories that reside in your wp-content directory for you to try and exclude then run the backup. To exclude files you will want to go to Snapshot > Settings > Global File Exclusions. There you will see that I already set the correct path, you just need to change the last path to the directory you wish to test. Then click save, and try to run your backup :slight_smile:

    I hope this helps!

    Take Care,

    Ken - WPMU DEV Support

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.