Managed backup not running

The managed backup is not completing.

  • Adam Czajczyk

    Hello Ed

    I hope you're well today and thank you for your question!

    I checked your site, made some small changes in Managed Backup configuration and run it manually - it completed fine (you can see it's there on "Snapshot -> Managed Backups" page). You might want to go to Managed Backup settings and set schedule there to suit your needs but I believe it should be working fine.

    The changes I made were:

    1. I removed two "define" lines from those added during the chat; you can see current set of those lines in the "wp-config.php" file of the site
    2. I excluded some big files from snapshot. This is something that was actually breaking the snapshot process - there is a huge .zip file in the root folder of the install and some backups from other plugin that are also quite big. There's no point in backing up a backup and the .zip file is not a part of WordPress as well. It is also too big in that sense that due to it's size the server is not letting the plugin to fully process it.

    If you go to the "Snapshot -> Settings" page in the backend of your site, you'll notice a list in a "Global Exclusions" field. The first one is ".zip" so it excludes all .zip files. In case you do have some .zip files on site (e.g. in Media Library) that you'd like to keep you can replace that one with a full name of a big zip file from the root folder of you install - but that one has to be excluded.

    After this changes the backup got created without any issues at all and when you schedule it should also be working fine, I believe.

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Ed

    Are the "symptoms" exactly the same? Is the site hosted on the very same server or some other? Let me know please.

    You might want also to start with checking the site for very big files as this is often an issue - the server is not able to handle some big ones. Usually these are files like backups made with other plugins (such as e.g. Updraft), some big .zip files that were uploaded to the server and similar.

    You might need to use FTP or cPanel "File Manager" to review that site's setup to be able to identify those files and if you find any you can exclude them from backup on "Snapshot -> Settings" page in your site's back-end, in "Global Exclusions" option. Just take a look at the current content of that option on a site we've been dealing with so far - to see an example (but remember that on that other site files/folders might be different).

    If that doesn't help, I'll need to check these other sites as well.

    Best regards,
    Adam

  • Adam Czajczyk

    Hi Ed

    Thanks for granting access. I checked that other site and finally I was able to go up to about 60% of progress with no issues, then I was just logged out of WordPress. However, it seemed to go fine.

    I understand that you had the same issue there as on the site we were dealing so far, right? Since it's a different server and different site configuration the issue might be caused by different reasons but I'm wondering whether it isn't/wasn't a resource usage issue.

    I noticed that Snapshot on the site is a couple of versions back so could you please update it to the most recent one (as there's been some fixes related to Managed Backups included) and then if you got some site stats available (e.g. Google Analytics) check at what time of the day and days the site receives the less traffic - then try to manually run backup then and see if it completes?

    Let me know about result, please.

    Kind regards,
    Adam

  • Ashik

    Hi Adam,

    Thank you for your reply.

    As my investigation Snapshot working well to take backup of your site. I can see Snapshot took the last backup on 3rd December. Screenshot attached.


    Also, I've tried to take another backup for confirmation and as usual it was working fine. Though I didn't push it to complete and cancelled it on 25%.

    Let me inform one important thing, currently Snapshot taking backups manually as there is no schedule in settings to take backups automatically. To take automatic backups, go Dashboard > Snapshot > Managed Backups > Settings > Enable schedule backups set your schedule and you're done.

    Feel free to reply here if you've any more questions or concerns about this issue. Have a great day ahead.

    Regards,
    Ashik

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.