Managed Backup to WPMUDEV 10GB Storage Always Fails

Using the Hub to backup our wptesting.org MU instance to the WPMUDEV storage. I always get this error (see attached image):

  • Nastia
    • Support Rock Star

    Hello Kevin

    I'm sorry to hear that you have this issue.

    General backup errors doesn't provide sufficient information. Please navigate to Snapshot > Managed backups and have a look at the log file by clicking on "View your log file" like it's shown in the attached screenshot:

    If you'll see any errors, please let us know.

    Please increase the PHP Memory limit and max_execution_time of your site and try to back up again your site.

    Ddd the following line to your wp-config.php file to increase PHP Memeory limit:

    define('WP_MEMORY_LIMIT', '3000M');

    At this rule at the bottom of the .htaccess file to increase max_execution_time:

    php_value max_execution_time 180

    If the issue still persists, please grant access from WPMU DEV > Support so I can have a closer look.

    Please see the detailed instructions on the link below:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Cheers,

    Nastia

  • Kevin
    • Site Builder, Child of Zeus

    Here are the errors in the log file. A lot of these, but nothing else:

    [Cron][2017-03-14 20:19:52][Warning] Immediate hook misfired, kickstart backup processing

    [Cron][2017-03-14 20:27:21][Warning] Immediate hook misfired, kickstart backup processing

  • Denitsa
    • WordPress Warrior

    Hey there Kevin,

    I hope all is well with you!

    Could you please access your server via FTP, edit the wp-config.php file and add the following lines just above the /* That’s all, stop editing! Happy blogging. */ comment?

    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    This will enable debug log that will be saved to a debug.log file inside the “/wp-content” folder. Please save the file as a .txt and attach it to your next post.

    Let us know how it goes!

    All the best,

    Denitsa

  • Kevin
    • Site Builder, Child of Zeus

    After making all the recommended config changes, I still get a “General Backup Error”. The Managed Backup log looks like this:

    [Cron][2017-03-17 01:06:14][Warning] Immediate hook misfired, kickstart backup processing

    [Cron][2017-03-17 02:06:10][Warning] Immediate hook misfired, kickstart backup processing

    [Cron][2017-03-17 02:06:15][Error] Error processing automatic backup: backup

    [snapshot][2017-03-17 02:06:17][Error] Error finalizing manual backup: backup

    The debug log is attached.

  • Denitsa
    • WordPress Warrior

    Hey there Kevin,

    Yes, unfortunately that’s true. So, could you

    Please save the file as a .txt and attach it to your next post.

    as I asked above? This way you’ll be able to attach it here.

    When you open the debug.log in the text editor of your choice, please go to File -> Save us and write debug.txt in the name box. It could look a lot like this (using a different text editor should be very similar):

    Don’t forget to hit Save afterwards and attach the .txt file here.

    Another option would be to upload the file to an external source such as Dropbox for example and providing us with the link.

    Looking forward to hearing back!

    Cheers,

    Denitsa

  • Kevin
    • Site Builder, Child of Zeus

    Ok. Let’s try again. BTW, the file I tried to upload previously was named debug.txt, but it was a zipped file that I renamed from debug.zip to debug.txt. Apparently, that does not work on this support site. So, following your instructions, I have 1) opened the debug.log file in an editor, 2) saved the file as a text file, 3) named it debug.txt. It still will not upload, probably because it is 357MB in size (413 Request Entity Too Large). So, here’s a link to it on dropbox:

    https://www.dropbox.com/s/jnhycuvtuaorc4p/debug.txt?dl=0

    Let me know if you got that.

    Thanks,

    Kevin

  • Denitsa
    • WordPress Warrior

    Hey there Kevin,

    Yep, you can't upload attachments of that size here, I'm sorry I didn't realise that was the problem.

    Actually, that's a fairly big file for just a debug log and I can see most of it is one and the same error and the other errors I could see were connected to your caweb-dev plugin too, so it seems it has some pretty serious issues.

    Could you please disable that and try to run a backup again? Creating a new debug.log beforehand (you can delete that one or empty it) and sharing it again would also come in handy, as that one's ~2 million lines.

    All the best,

    Denitsa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.