Managed backups don't upload to the Cloud

No of my managed backups were uploaded to the cloud. Snapshot logs shows the following error:

[Remote][2018-02-15 15:18:36][Warning] Unable to finalize the upload
[Remote][2018-02-15 15:18:41][Warning] Error continuing upload, unable to determine target paths for: 1518707870
[Remote][2018-02-15 15:18:50][Warning] Error continuing upload, unable to determine target paths for: 1518707870
[Remote][2018-02-15 15:18:56][Warning] Error continuing upload, unable to determine target paths for: 1518707870
[Remote][2018-02-15 15:18:58][Warning] Error continuing upload, unable to determine target paths for: 1518707870
[snapshot][2018-02-15 15:19:00][Error] Error finalizing manual backup: upload

My Cloud storage is empty, so there's for sure enough space to upload backup.

There seems to be nothing relevant in debug.log

  • Katya Tsihotska

    Hi Ryan

    Hope you're having a wonderful day!

    I've got in touch with our developers and they informed me that the following error in log means that the local backup file the plugin was looking for isn't there anymore.
    Error continuing upload, unable to determine target paths for: 1518707870
    I've tried to check if the backup archive we've created yesterday persists in the needed folder, but it looks like you've removed some of the backups created yesterday, so I cannot check this. I've tried to create another managed backup, but I've got the same error as we got during the chat, before resetting files/folders ownership and permissions.
    General backup error

    Let me know, did you make any changes to this after the chat or did you change anything else in server configuration? If so, could you please revert the changes and create another managed backup, so I'll be able to check if the newly created backup is stored in the correct folder and has the correct name? Let me know once you'll do it or let me know if you didn't change anything.

    Kind regards,
    Katya

  • Ryan

    Hi Katya,

    My apologies, I had not removed any backups or made any changes at the point that you checked last. But in the time since, we had reset the server setting it up with CentOS 7 instead of Ubuntu 16.04 server hoping that it might play better with Caddy Web Server and possibly take care of some of these issues.

    But it seems that we are still having the same issue throughout this entire process. I've looked where its supposed to be creating these backups and dont see anything there at all.

    This leads me to the conclusion that nothing is actually being created, maybe a folder permissions issue is preventing the plugin from working correctly and the "failed to upload" issue really stems from a "failed to create" issue.

    What permissions and groups and directory ownership needs to be in place for the backup plugin to make a full site backup? Currently the user and group that owns my Wordpress directory is caddy:caddy

    Thank you

  • Katya Tsihotska

    Hi Ryan

    Hope you're having a great day!

    By default, it's recommended to use 644 permissions for files and 755 for folders.

    As for the ownership it depends on your server/hosting configurations, on some hostings each process on the server is launched by the certain user (hosting user), in such cases, user and group can be same. So if the user of the panel is user1 then the group should be user1 as well. But on some hostings, the user should be user1 and the group should be a web-server group (often it's www-data). But I would recommend you to contact your hosting provider as they should better know which configuration will be more suitable in this case.

    I've tried to perform another managed backup and it was successfully created but wasn't uploaded to our Cloud.

    As for the scheduled backups, Snapshot uses WP Cron to run scheduled backups, and wp_cron triggers only when you have a visitor on your site, if you don't have much traffic on the site, then it's better to replace WP Cron with a system cron job. Here you'll find detailed documentation about how to do this:
    https://premium.wpmudev.org/docs/using-wordpress/how-to-use-system-cron/

    Please, try to also run a plugin/theme conflict test as illustrated in getting support manual (flowchart) to make sure that no of your plugins or theme doesn't prevent the uploading of the backup. Let me know how it goes.
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/
    The main goal is to deactivate all plugins, switch the theme, run another managed backup and check if it'll be uploaded to the Cloud in this case. Let us know about results

    Kind regards,
    Katya

  • Ryan

    Hi,

    Sorry for the very delayed response to this ticket. This server was down for the past several days as the server hosting this slice updated and I was unable to get some of the services to start and run afterward.

    That being the case, I went through and attempted to start cleaning up the file system. During that process, I noticed some things that might be in conflict and removed them.

    Then I removed php7.2 and all extensions previously installed, disabled the php7.2 repo, enabled the php7.1 repo, installed php and required extensions.

    Did the same thing with Caddy, my web-server.

    Im not sure exactly what the solution ended up being, but it seems to be working the way its supposed to be at this point.

    Thank you for all your help!

    Ryan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.