Managed Backups fails

Managed Backup fails, 504-time getaway is showing up. There is only one site in the public_html folder. Max execution time is 120 and can't get higher because it is limited by the host.

  • Majid

    Hello mark
    I hope you are doing great today :slight_smile:

    I noticed that you have a lot of big files in your /public_html directory that I'm sure they are not needed to be included in the backup, like a giant error log file and some old backups, beside these core.XXXX files

    All of these files will increase the execution time which eventually make Snapshot timing out before finishing the job since the managed backups take everything in the /public_html (the directory where WP is installed)

    I suggest moving the files that are not really needed to be in the backup to another folder outside the /public_html and running a new Snapshot Managed Backup.

    Let us know how it went.

    Majid

  • mark

    hey majid, thanks for the reply it says core files? i am not a programmer, so i wouldn't know where to move them. is there a way you could do this for me as i would believe if i touch it i would "stuff it up"
    the whole thing, and then good luck working out? feel free with your judgement to do this, i trust you as you would know more than i do ( close to nothing >< )

    Let me know and thank you in advanced!

  • Dimitris

    Hello there mark,

    hope you're doing good today! :slight_smile:

    I've went ahead and made some changes, but I'm still getting the same 504 timeout error.
    What I've done:
    wp-config.php

    // Snapshot settings - start
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 10);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_FILESET_USE_PRECACHE', true);
    define('SNAPSHOT_FILESET_LARGE_FILE_SIZE', 104857600); //100MB
    define('SNAPSHOT_IGNORE_SYMLINKS',true);
    define('SNAPSHOT_FORCE_ZIP_LIBRARY', 'pclzip');
    define('SNAPSHOT_ATTEMPT_SYSTEM_BACKUP', true);
    define('SNAPSHOT_BACKTRACE_ALL', true);
    // Snapshot settings - end

    Global File Exclusions

    public_html/wpmucore
    public_html/wp-content/cache
    public_html/wp-content/1cache
    public_html/wp-content/cache.disabled
    public_html/wp-content/backupwordpress-7ba1af0608-backups
    public_html/wp-content/ai1wm-backups

    I've already created a report for our Second Level Support team, so they can further investigate this. Please keep in mind that their response times are a bit larger than ours in first level support. Your patience here is highly appreciated! :slight_smile:

    About the weird core.number files that are getting found in root folder, this means that some other plugin most probably is causing that.
    https://www.siteground.com/kb/core-xxxxx-files/
    The best way to sort this out, is by performing a conflict test, meaning to deactivate all plugins or themes one by one, until these stop regenerating.
    https://premium.wpmudev.org/wp-content/uploads/2015/09/Support-Process-Support-Process.gif
    It would be even better, if you could create a staging site for this, meaning a complete and exact copy of this installation into another location/folder in the same server, using a separate database, so you don't mess up with live site (especially if you don't have any kind of backup, that you could restore in case of losing any settings during the conflict test).

    Warm regards,
    Dimitris

  • mark

    Hello Dimitris and thank you very much for this , i got an email today from my current hosting i transferred 4 days ago here and i got an email notification saying that i used 90% of my monthly resources, the first 2 were jetpack, the tech guy did a cron job for it as i have no idea what to do. did the core files got recreated again? i need to check the public folder again. i cant create a staging site i need to be on a higher plan for this unfortunately. the only thing i can do is deactivating but then it stuffs up live .... ><

  • mark

    Hello Dimitris i hope you are doing well, since i changed plan and it allowed me to do staging for my website i went ahead and did this.
    issues were still there. i deactivated all plugins, ,ho,wever your hummingbirdpro created an gateway error 502 i think which i got the tech to manually disable.
    all plugins are now disabled and only snapshot and plain theme, errors still exist.
    i also tried seperate url crawl in crawler pro as i had an issue there too, deactivated all plugins plain theme error is still there.. i have screenshots attached...

  • Panos

    Hi mark ,

    One of the devs had a look on your site. He managed to do a complete managed back up by excluding the uploads-old folder.

    He informed me that he lost ftp access. Although it could be temporary, could you please connect and comment out line :
    define('SNAPSHOT_BACKTRACE_ALL', true);
    from the wp-config.php file so it doesn't add up so many logs?

    Could you also do a test and let us know how it goes on your side too?

    Thanks!

  • Dimitris

    Hello there mark,##1

    hope you're doing good today and I'm really sorry for the frustration here.

    As you may understand, some issues are site/server specific, like the one here about Managed Backups, or the one you had about HummingBird, which got resolved after migrating into another server. As for the SmartCrawl issue, this is something supposed to happen and we're waiting for a plugin update to fix this.

    If more assistance is required on these subjects, please post in the relevant thread, and for any other please do reach us here https://premium.wpmudev.org/hub/support/#get-support
    We're always happy to help! :slight_smile:

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.