Managed Backups Not working

I have managed backup set up on multiple sites and it works great except for this one. Scheduled ones have not run and when I try to do a manual one I get an error message "oops, something went wrong". Access has been granted
Thanks

  • Adam Czajczyk
    • Support Gorilla

    Hello Chris,

    Thank you for granting access!

    The issue here seems to be an "error_log" file which is extremely big. It's about 1.7G in size and there's a 1GB threshold. The file is an error log of Apache web-server and it's a text-only file so if it got that big it has probably "grown" there from the very beginning since you opened that hosting account.

    The file will recreate itself (much smaller though) if necessary so it's safe to remove it. You would find it in a root folder of your site (/home/topcoat/public_html/). Give the Managed Backup a try after you remove the file and I think it should work as expected.

    Let me know please if it did.

    Best regards,
    Adam

  • Dimitris
    • Support Star

    Hey there Chris,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Are there any other large files involving here? Could you please connect to your server via FTP and check that out? You can also try to exclude large files from snapshots and test if that makes any difference. You can do so via Snapshot -> Settings -> Global File Exclusions

    If this isn't the case here, let's proceed with some basic debugging. We'll try to increase the allocated to PHP memory, use smaller chunks of files and DB tables during snapshot backup process and enable WP_DEBUG to log any related error messages.

    Before doing so:
    - ensure that no manual backup is running
    - temporarily disable automated backups

    Then please access your server through FTP edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the followings (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    // https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
    define('WP_MEMORY_LIMIT', '256M');
    // Snapshot definitions
    // *Important:* the chunk sizes have to be fixed for each backup. So, if you'll be making use of this define, please make sure there's no manual backup running and temporarily disable automated backups.
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    If you still get errors, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply (if file is larger than 5MB, please use a service like Dropbox and post the shareable link instead).

    Finally, please install a little plugin which could help us review all cron jobs running to your installation. https://wordpress.org/plugins/wp-crontrol/

    Warm regards,
    Dimitris

    PS. I also noticed that you're using a rather old PHP version (5.3) which isn't supported any more and it's rather slow comparing to the latest versions (7.x). I'd rather advise to update at least in version 5.6 or in 7.0 if possible which is more stable and fast!
    Reference: http://onlinephpfunctions.com/benchmarks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.