Managed Snapshot Backups don't work.

Backups are set to run each night at 4am but although the top of the page shows:
Automatic backup currently running, the last backup is from October 2nd.

  • Dimitris

    Hey there chrisatx,

    I hope you're doing good and thanks for reaching us!

    I just went ahead and activated the error log in Snapshot -> Managed Backups (Settings).
    If this isn't much for you, can you just leave it as is in order the next cron job to trigger? This is going to happen approximately at "Saturday October 8, 2016 at 11:00am." your server time.
    The debug file may contain valuable information for our our dev team. :slight_smile:

    Meanwhile, could you check your Hub here https://premium.wpmudev.org/hub/my-websites/
    and check:
    1. that you haven't reached the 10GB limit for managed backups
    2. that the latest backup is since October 2 indeed

    Warm regards,
    Dimitris

  • Adam Czajczyk

    Hello chisatx!

    I accessed your site and checked it again. I remember we fixed another issue (regarding manual Managed Backups) previously and that was around the date your latest automated backup was created. I checked the dates then but it seems that this is not related as last automated backup was created after we dealt with manual backups :slight_smile:

    That said, I disabled automated backups, changed error loggin settings more and enabled backups again. Your next backup should run on tomorrow at 8 your time.

    Let's again wait until then and a few hours later I'll get back to it and check error logs again. I would however want you to do one more thing before that scheduled backup is fired:

    make sure that these lines are in your sites "wp-config.php" file"

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);
    define('WP_DEBUG_DISPLAY',false);

    These lines should be located above the "/* That's all, stop editing! */" line.

    Then, after the scheduled backup should be triggered (give it additional two, three hours please) download the "debug.log" file from "/wp-content" folder on your server, rename it to "debug.txt" and attach to your replay here, please.

    I hope this will point us in a right direction.

    Best regards,
    Adam

  • chrisatx

    Hi Adam,

    And thanks for the email. I was not aware the emails did not show up here automatically :wink:.

    I have made the adjustments to the wp-config.php file a few days ago and made sure the backup schedule was set to daily. However, no backups were created.

    A few days ago when you emailed me, about 10 minutes to half an hour before your email, the server seemed non-responsive. I tried to log in to admin panels or even browse some pages but even after a minute nothing happened. Not sure if Snapshot was draining resources. It was an off-peak moment though, the load is low on that server and hardly anyone knows the URL. I do think it was related to Snapshot.

    Can you keep an eye on that as well? I have no clue as to what is the cause of the problem...

    Thanks,
    Chris

  • Milan

    Hello Chris,

    Hope you are well today and won't mind me chiming here.

    I checked your error log file and found few warnings being generated which are,

    Immediate hook misfired, kickstart backup processing

    and to get more information about this, I would need to ping our developers but before I do that, i would need below information from your side, so please provide me below requested information and I'll ping our developer.

    #1) Your hosting provider
    #2) Server's location ( This is not too much important but it would be good if we have it for our developer. If you are not sure about this, you could ask to your hosting provider about this. :slight_smile:
    #3) RAM and Processor information.

    If you are not able to get last two requested information, please do let me know about your hosting provider.

    Look forward to hearing back from you. :slight_smile:
    Best Regards,
    Milan

  • Predrag Dubajic

    Hi chrisatx,

    That should be more than enough for running the backup process.

    I would like to perform couple of more tests but testing snapshots can take bit more time and our support access has expiration timeout so I got logged out during the backup process.

    Could you send me your wp-admin login details so I could test it without getting logged out?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/ and the template below:

    IMPORTANT: Make sure you select "I have a different question" for your topic so it doesn't go back to forums - this and the subject line ensure that it gets assigned to me.

    Subject: "Attn: Predrag Dubajic"
    - Site login url
    - WordPress admin username
    - WordPress admin password
    - Link back to this thread for reference
    - Any other relevant urls

    Best regards,
    Predrag

  • Dimitris

    Hey there chrisatx,

    I trust you're doing good today! :slight_smile:

    This message from your error log
    Immediate hook misfired, kickstart backup processing
    means that the automated backups request cascade failed, and it's falling back trying to continue the backup process via cron.

    Could you please contact your hosting support channel and ask if there's anything that might block these requests to our API? The domain that should be white-listed is premium.wpmudev.org and your website should be able to perform POST HTTP requests (and cURL requests on fallback).

    I look forward for your feedback on this! :slight_smile:
    Warm regards,
    Dimitris

  • chrisatx

    Hi Dimitris!

    Before I ask them, as our setup should be the stock A2 Hosting set-up, let's see if we can find a reason.

    1) Could my running Cloudflare on the naked domain have anything to do with it?
    2) I am protecting the sites with the .htaccess plugin as they are being built.
    3) There is no traffic for the same reason as number 2.
    4) The site was hardened with the WPMU Dev Defender Plugin.
    5) UpdraftPlus is working fine though.

    -> Can we find a solution that it can work under this situation? Especially in development mode backups are important for each change that I make.
    -> Is there a way that I can check those POST HTTP + Curl requests myself? I'm on the other side of the planet, it's getting late in the evening and I'd like to optimally use our time, instead of waiting for support of my hosting provider?

    Have a great weekend!
    Chris

  • Dimitris

    Hey @chrisatx!

    1) Could my running Cloudflare on the naked domain have anything to do with it?

    Could be a possibility indeed. Can you please deactivate it or maybe use the development mode so that no caching will be involving and deactivate any other modules from its control panel?

    2) I am protecting the sites with the .htaccess plugin as they are being built.

    Could you please save your .htaccess file as htaccess.txt and attach it here in your next reply to have a look?

    3) There is no traffic for the same reason as number 2.

    In which "traffic" do you refer? Please advise!

    4) The site was hardened with the WPMU Dev Defender Plugin.
    5) UpdraftPlus is working fine though.

    This shouldn't be the case here. On the other hand, you can try disabling all of your plugins and run another manual managed backup. :wink:

    -> Can we find a solution that it can work under this situation? Especially in development mode backups are important for each change that I make.

    I would be more than happy if I could provide such a workaround, but all the evidence we have right now, simply don't allow us to do so.

    -> Is there a way that I can check those POST HTTP + Curl requests myself? I'm on the other side of the planet, it's getting late in the evening and I'd like to optimally use our time, instead of waiting for support of my hosting provider?

    Unfortunately, this is something that can be only be checked for sure by the server admins.

    Take care,
    Dimitris :slight_smile:

  • chrisatx

    Hi Dimitris,

    1) I've already put it into development mode. At the moment it's bypassing it completely.
    2) It's using a plugin with the credentials I've sent earlier by the form (privately)
    3) The website isn't public so if it would rely on external hits to trigger the script it won't work as it's private.
    4/5) Please not :slight_smile:. I'm actively building the site at the moment.

    I've gotten back word from A2 Hosting. Nothing is blocked so all is working. They told me to let you know that there is a 2.5Mbps I/O disk limit though.

    Chris

  • Predrag Dubajic

    Hi Chris,

    Could we go a step back here as I did some more tests on your installation and this time I was able to complete backup with Uploads folder excluded so it look something there is causing this.

    Based on the information you provided before this shouldn't be happening because there are no huge files there.
    However could you try excluding your month folders from Uploads folder one by one to see which one is causing the issue?

    You can exclude folders from Snapshot > Settings tab.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.