Manged backup via automate fails

Have enabled "Auto backup before every update" in Automate, but it doesn't seem to create any Manged backups.

Manual full backups via Snapshot plugin seems to work fine.

  • Michael

    Hi Nithin,
    I have been working on the automatic backup issue with Cloudways. They asked me to try turning off Varnish cache.
    Unfortunately the automatic backup still didn't work, even with Varnish turned off server wide.
    Any other ideas?
    Do you know if anyone else successfully runs WPMUDEV snapshot on Cloudways?

    Other changes I have also made are:

    The following code has been added to the wp-config file:
    // Change Snapshot file chunk size
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 100);

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);

    In Cloudways - Server Management - Settings & Packages, I have also increased the Execution Limit to 600 seconds and the Memory Limit to 256 MB. That also didn't fix the problem.

    I have also added the wpmudev server IP address to the cloudways security whitelist (
    66.135.60.59, 66.135.49.214, 66.135.60.64)

    The backups still fail, with the following error:
    [Cron][2017-10-09 20:05:08][Warning] Immediate hook misfired, kickstart backup processing

    Regards,

    Michael

  • Kasia Swiderska

    Hello Michael,

    We have one staff member that is running Snapshots and Automate on site on Cloudways. They double checked and it's working on three test sites on Cloudways.
    This is their package: DigitalOcean with 1GB RAM, 1 CPU core and 30GB disk - can you share yours?
    I see that you have enabled debug.log on site, can you send us using Dropbox or gdrive this file? It will be in the wp-content directory.

    kind regards,
    Kasia

  • Michael

    Hi Kasia,

    I am on Cloudways Vultr, 1GB Ram, 30GB, 1 core.
    I don't want to link to a copy of my debug log on this public forum.
    Would you please send me an email address that I should send this too, or show me how to make my replies here private.

    I did resolve the issue with Cloudways last night with the help of Cloudways staff.
    Below is what I had to set:

    Added the following to wp-config:
    define('WP_MEMORY_LIMIT', '512M');
    define('WP_MAX_MEMORY_LIMIT', '512M');
    // Change Snapshot file chunk size
    define('SNAPSHOT_TABLESET_CHUNK_SIZE', 100);
    define('SNAPSHOT_FILESET_CHUNK_SIZE', 50);
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);

    On Cloudways:
    Disable caching plugin (Breeze)
    Disabled Varnish cache
    Set execution limit to 600 seconds and memory limit to 256mb
    Whitelist the WPMUDEV servers (66.135.60.59, 66.135.49.214, 66.135.60.64)
    Set the following in Cron Job Management:
    */5 * * * * wget -O /dev/null https://justfunmovies.com/wp-cron.php

    I obviously hope to not require all the above for each site I host to make this work, but I am not sure which one made it work. The final items I changed, which coincide with the automatic snapshot backups working was turning off varnish, setting the memory limits to 512M, and setting the cron job.
    I will now proceed to turn Varnish back on and see if the backup and plugin update occurs next time an update becomes available.

    As a comparison, I tried automatic backups via perfectdashboard.com for 2 other sites on the same cloudways server and they successfully backup each night with no problems (and no need to do the above settings). They have been backing up for a week or so now, before I started changing the above setting, and have not failed during all the above changes.
    I would love to know why their system works (which I pay for separately of course) but the wpmudev backup and snapshot didn't.

    I also suggest you get your document writers to update the Usage section on https://premium.wpmudev.org/project/snapshot/
    I spent many hours trying to get those features working in my Snapshot settings before finding out that the Usage instructions are outdated and no longer apply.

    Michael

  • Kasia Swiderska

    Hello Michael,

    I'm very sorry about the delay. Thanks for the debug.log - problem is that inside it there was nothing that pointed to Snapshot. No errors about WPMU DEV or specifically Snapshots. There was no errors about timeouts or memory limits.
    Its full of notices and some rare errors related to plugins (pizazzwp-architect, wp-postratings).

    There was one strange error

    PHP Warning: Error while sending QUERY packet.

    But it showed only once, and this can be fixed with changing value of max_allowed_packet - but I dont see that in changes you made, so it also doesn't seem related to snapshot issue.

    I will now proceed to turn Varnish back on and see if the backup and plugin update occurs next time an update becomes available.

    Does turning on Varnish broke the Snapshot again? Were there any updates available?

    I also suggest you get your document writers to update the Usage section on https://premium.wpmudev.org/project/snapshot/

    I've send message to our writer and they are preparing new documentation for Snapshot.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.