Manifest file is not being greated with SnapShot Backup

Backup file is being created apparently but manifest files are not being created. Please assist, Thanks.

  • Tim
    • WPMU DEV Initiate

    Hi,

    I've been able to track down and solve the problem. Somehow Wordpress was trying to write the manifest file with 'ftp_fput' and not 'fopen' / 'fwrite'

    The plugin did not detect correctly there were file writing permisison issues and the code did not check if the manifest file was ever written and added to the zip. So no error was thrown anywhere.

    I solved the issue by adding
    define('FS_METHOD', 'direct' );
    to my wp-config, which causes Wordpress to write the file with 'fopen'.

    Thanks for the help!

  • Tim
    • WPMU DEV Initiate

    jasonhunter i don't think i fully undertand your question. In my case, the plugin used different Wordpress core mothods to write different files to the server to create the backup zip file. Due to Owner / Group permissions and inconsistencies, the manifest file could not be written to the server. My solution fixed the permission issues.

    I did not create any 'real' backups before i solved my issue as the backups were useless without the manifest file.

    If you mean you have a zipfile of a backup of a website that no longer exists and you don't have a manifest file in your backup file, you need to manually import all mysql-tables in the zip file and upload your images manually too. There will be a lot of manual stuff you need to to if you want to 'import' this zip as the Snapshot plugin cannot import it without the manifest.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.