Manual appointments not blocking off time

when I manually schedule appointments or when my google calendar blocks off time the plugin doesn't recognize and block off the entire time. For instance: I manually schedule an appointment for 4-6pm. A+ has my schedule still available to accept a 3 pm appointment and a 5 pm appointment (2 hr blocks) since the appointment doesn't fit the description. Is there a way to fix this?

  • Patrick

    @Steve

    Hope you had a good weekend!

    Sorry to see you're having difficulty getting this working for your needs. Let's see if we can things sorted before abandoning hope. :slight_smile:

    I've been testing on my own dev site to try to figure this out with no satisfactory results unfortunately.

    I had set up services with durations in multiples of 2 hours. For example, booking at 8:00, 10:00, 12:00, etc. Then set up a manual appointment for 4 hours from 9:00 to 13:00. Only the 10:00 to 12:00 was blocked off in my tests regardless of which time slot calculus method I selected.

    I'll alert the plugin developer to this thread to see if he can provide some more insight into this.

  • Steve

    All right @Dean Kaus, I think I've waited a "reasonable" amount of time for a solution without one coming. It seems to me you have a choice of refunding my money and letting me go as a slightly dissatisfied customer who feels you guys did your best, or keeping my $19 and letting me be very pissed off and bad mouth your company to everyone I speak to and no possibility of me returning in the future. Which would you prefer?

  • pxwm

    Hi @Steve

    I've been following this post and based on the issue you describe in your original post and if I've understood your problem correctly then I would suggest the 3 to 5 time slot would not be available.

    I'm also assuming you have:-

    1 x Service Provider
    1 x Service with a duration of 2hrs
    You scheduled working hours from your example is 3 p.m. to 6 p.m.

    If I'm correct with your assumptions then you could accept an appointment from 3 to 5 or 4 to 6.
    There are other options dependant on the 'Time Base' settings but lets assume your 'Time Base' is set by the Service duration for this example, which is the default setting in v1.3.1.

    You then block off a time slot from 4 to 6 either with an appointment or you block in your Google Calendar.

    Then this only leaves a 1hr time slot from 3 to 4 and as your Service duration is 2hr then it is correct that it doesn't allow an appointment to be made at 3 p.m.

    Could you please confirm if my assumptions are correct and if so why you think you should be able to book an appointment from 3 to 5?

    Regards
    SteveB

  • Steve

    The assumptions are correct. I'm not understanding your post. I don't want to schedule an appointment from 3-5 or 5-7 when I have an appointment at 4-6, but the program still offers those blocks to be scheduled. That's the problem.

    As I noted in my initial post: I manually schedule an appointment for 4 to 6 pm when the program sets up my appointments for odd hours (3, 5, 7, etc) all 2 hour blocks. The program has the 3 and 5 slots marked as AVAILABLE even though I have a schedule conflict in between from 4-6. Obviously I would not want the program to schedule another appointment from 3-5 or from 5-6 because I would then be double booked and unable to meet my commitment.

    What I would like the program to do is see what blocks are available and schedule accordingly. For instance, in this case when I manually schedule an appointment that conflicts with the schedule to adjust and open blocks around for even hours. I know that would be a lot to ask for, so I would be satisfied with the program simply not offering the appointments that conflict with what I manually schedule.

    Is that clearer?

  • pxwm

    Hi @Steve

    Many thanks for the clarification.

    I agree this should certainly block out the time slots when you book a manual appointment in the A+ backend.

    Could you please confirm how you are making the manual appointment through the A+ backend?

    However if you are blocking from your Google Calendar this can take 15 mins to sync with A+ and only if you have the 'Integration Mode' field in the A+ 'Google Calendar' tab set to 'A+<-> GCal (Syncronization) (syncs both ways)

    Could you please confirm if you have this field set to sync both ways?

    Could you also screenpost the following A+ settings:-

    'General' tab - all the settings but you may have to post sections of the page
    'Services' tab
    'Working Hours' tab for the single 'Service Provider' and the 'no specific provider'
    'Service provider' tab
    'Google Calendar' tab

    To confirm there is a way to set the time slots hourly and you can achieve this by:-

    Login to your Wordpress dashboard as Admin
    Then Select the 'Add-ons' tab
    Then Activate the 'Durations' Add-on
    Then Select the 'General' tab
    You will now see a new field called 'Time slot calculus method' in the 'Time Settings' section
    Select the radial button for the 'Minimum time based appointment duration calculus (legacy)' field
    Then set the 'Time Base' base field to 60mins
    Then Save

    This should now display hourly slots in your schedule based on the Working Hours set: 3, 4, 5, 6, 7 and will allow appointment to be made 3 to 5, 4 to 6, 5 to 7

    Regards
    SteveB

  • Steve

    I am making the appointment from the appointment page where it says "add new."

    I understand that it takes activity on the website and time for the google calendar to update, but it is still causing the problem even though the google calendar has already blocked off the time. Yes, it is set up to sync both ways.

    As you can see from one of @Patrick Cohen posts he stated: "I've been testing on my own dev site to try to figure this out with no satisfactory results unfortunately.

    I had set up services with durations in multiples of 2 hours. For example, booking at 8:00, 10:00, 12:00, etc. Then set up a manual appointment for 4 hours from 9:00 to 13:00. Only the 10:00 to 12:00 was blocked off in my tests regardless of which time slot calculus method I selected."

    I'm posting the requested screen shots. I adjusted some of the values after the shot based your suggestion for the time slot calculus. This did open up some options for scheduling hours, but did not fix the problem of it not blocking off the scheduled time slots.

  • pxwm

    Hi @Steve

    I've checked your settings and they all look fine except:-

    You don't appear to have any Service Providers created and I suspect this may be the problem.
    You have 3 x Services setup called: Initial visit, Followup, 1hr and Followup, 90mins but you have all three set to 120mins.

    I'm not sure how many Service Providers you have but could you create a single Service Provider and assign them to the 3 x Services.

    Then Select the 'Working Hours' tab
    Then Select the 'no specific provider' from the dropdown and then set all the 'Work?' fields to 'No'
    Then Select the 'Service Provider' from the dropdown then set the 'Work?' fields to 'Yes' for the specific days and set any relevant 'Breaks'.

    Then test

    Regards
    SteveB

  • Steve

    That isn't the problem. I am the only service provider so it didn't make any difference that I put in a provider. What did help was the durations add in and changing the time base to 30 minutes. This gives me the scheduling flexibility that I want and the appropriate times are being blocked off for manual and web scheduled appointments. The problem is still there for times blocked off by gcal. Any fix for that?

  • pxwm

    Hi @Steve

    I'm pleased we have resolved the issue in respect to the scheduling times.

    I'd like to check the current settings in the 'Working Hours' tab.

    Could you please post the 'Working Hours' tab for:-

    The 'no specific provider'
    And for the single 'Service Provider'

    Could you also post all your shortcodes in the Appointments page with the page set to 'text' so I can view all the code.

    Regards
    SteveB

  • Steve

    I recreated the schedule page because I was suspicious that you would tell me that the changes I had made were causing the problem, but that isn't the case. Here is the page that is the default page when the setting to create a page is selected. Still the times that are blocked off by gcal are incorrect. At this point it's not a huge ordeal and I'm somewhat satisfied by how it works, at least I'm willing to use it.

    Since I have your ear at the moment, there is one more minor problem. As you can see the work hours that are scheduled on mon and tue are shortened to just in the evening. I would like to set those to non-work days and then be able to open them up on an as needed basis. When I do that currently through the exceptions setting instead of just opening up the work hours that I have defined the program makes the whole day available. Is there a way to make just the hours that I have defined available?

  • pxwm

    Hi @Steve

    Just revised to include your further question about the 'Exceptions' tab which I have added to the bottom of my post.

    I've reviewed your settings and I'm not sure how the schedule is showing any available time slots as you state you haven't assigned the single Service Provider to the single Service yet all the Working Days for the 'no specific provider' are set to 'No', yet you have set the Working Days for your single Service Provider..

    There is a way you can create a single Service Provider, assign them to the single 'Service' and then 'force' the schedule to show the available time slots without having to select the 'Service Provider'.

    Login to your Wordpress dashboard
    Select A+ Settings
    Select 'Service Provider' tab
    Create the single 'Service Provider and assign them to the single Service.
    Make a note of the 'Service Provider 'ID'
    Then Save

    Then Select your Appointment page and revise the following shortcode

    From: [app_services]
    To: [app_services worker="x"]
    Replacing the 'x' with the 'Service Provider' ID

    Then remove the shortcode: [app_service_provders]

    This will then force the schedule to be displayed for your single Service Provider.

    As for your further question about controlling Working Hours within a Working Day or Non Working Day through the 'Exceptions' tab

    Unfortunately currently A+ only allows Days to be set and you cannot specify Hours.

    Regards
    SteveB

  • Vladislav

    Hello,

    The new plugin release (v1.4, just released) comes with the improved "Durations" add-on, which now supports toggling settings for appointment boundaries detection. You can choose between the exact period matching pattern (which is the old plugin default, and the cause of this kind of behavior), and overlap detection, which is the new way of calculating period overlaps and should hopefully fix this issue.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.