Manual Approval Required For Twitter With Every Comment

Hi all!

I'm enjoying trying out Comments Plus.

The plugin works perfectly with Wordpress and Facebook... meaning once I add a comment once then further comments are automatically posted.

But it appears that I have to approve Twitter comments every time.

Do you know of a way to allow Twitter comments to post after the first comment?

You can see my tests on this post:
http://www.sagerock.com/blog/my-2012-advice-you-probably-dont-want-to-take/

In Settings>Discussion - I have "Comment author must have a previously approved comment" checked.

Thank you for your help!
Sage