Manual Excerpts

Must I enter an excerpt on every post with Infinite SEO? When I fail to manually create an excerpt, the Google+ button and the Facebook button won't get anything from the Wordpress excerpt. Google+ gets the first text on the page and Facebook pulls nothing. If I manually enter the meta description then will it work? Why can't the meta be populated by the first lines of the post as a default? Or is something else going on?

The problem occurs on most posts on http://leadchangegroup.com/blog using either Facebook Share from AddThis. This all worked fine when I was using a different SEO plugin.

  • DavidM
    • DEV MAN’s Mascot

    Hiya!

    Let me make sure I understand this correctly to start with. If you have Infinite SEO deactivated and with there being nothing additional needed in the Excerpts area for the post, the first few lines of your post get included when using the features from the respective plugins you're using for sharing to Facebook and Google+, correct?

    I'm trying to check some things out with that but just wanted to be sure we're on the same page.

    Thanks,
    David

  • mikehenrysr
    • Design Lord, Child of Thor

    Actually, I thought this might be a bug in the Blogs-mu theme. When I went to Infinite SEO from Wordpress SEO, it fixed my titles that were being duplicated on Facebook and Google+ posts. But it started putting in text from the top of the HTML page "logo Already a member? login" etc. for the description. I just disabled Infinite SEO and the problem persisted. When I turned on Wordpress SEO, it got good descriptions and my duplicated titles again.

    So Wordpress SEO is fixing the meta description for Facebook and Google+ but hosing the titles and Infinite SEO fixes the titles but fails to get the meta description. This behavior is the same if I use Google+ in the browser or the Add This toolbox I have on my site and in my browser.

    So I went back to Infinite SEO and hand-edited the meta description on the post page. It worked perfectly. What I typed in the meta description box got pulled into the post on Google+.

    So is that "as designed?" Is the design such that we must manually enter the meta description on every post? Can't it default to the first line or so of the post? We have a number of authors and most never think about adding a meta description. So if it would default, that would be ideal.

  • mikehenrysr
    • Design Lord, Child of Thor

    Is anyone going to respond to this message? Every time I click a Facebook share or Google+ and we've forgotten to manually copy the post exceprt into the meta description field, I'm going to re-comment on this thread until it's answered.

    Can someone please tell me if you plan to fix this so that it defaults the meta description to the excerpt?

  • DavidM
    • DEV MAN’s Mascot

    Hi Mike,

    My sincere apologies for the delayed responses here! I originally tested this and I've really been trying to replicate the issue, but I just can't seem to do so. When I Share through the AddThis plugin to Facebook, it actually is getting the first line of the post, and I don't need to enter anything in the meta description.

    Is it possible you've got some combination of plugins that's causing the meta description to be required?

    Currently, I'm testing this all with the latest versions of WordPress 3.3 and Infinite SEO 1.3.5. It's a Single site though. Are you testing this on a Multisite? And what versions are you on there?

    -David

  • mikehenrysr
    • Design Lord, Child of Thor

    I'm still on 3.2.1, Add This 2.3.0 Infinite SEO 1.3.5.

    Some plugin may be causing this problem, but I don't know what to start disabling. I tried disabling the Woo Tumblog plugin, but it broke the page presentation the way it was integrated with my site so I can't test turning that off, at least not at this time.

    If you go to this post on my site you can see it in action. I can make Add This work perfectly by simply disconnecting Infinite SEO and connecting a different SEO. If I simply disconnect Infinite SEO, Facebook Share works, but Google+ still does not. If I install you-know-who's SEO, it works fine.

    So let me know if this means that I'm on my own or not. But it's going to take some time to do all the testing necessary if I do this by turning off plugins. I have a bunch.

  • DavidM
    • DEV MAN’s Mascot

    Sorry for the delay here, I actually thought I'd posted here. Basically, as I can't replicate this on a rather bare site, the only other thing I can imagine the issue would be due to is some sort of plugin conflict. If you've got a lot of plugins on that site, that's very likely the case.

    You might be able to check your error logs to get a clue as to what's occurring, but it's most likely you'd have to disable plugins to see where the issue's coming from.

    It is also possible it's due to your not being on WordPress 3.3 while other plugins have been updated for that version.

    There's just no other way to test further without ensuring finding the trouble point, which seems to be a plugin conflict, or perhaps a version conflict with WP 3.2.1.

    -David

  • Timothy
    • Chief Pigeon

    Hey Mike.

    Did you get this one sorted, we haven't heard from you in a while so I thought I would check in to get an update.

    If you got it sorted then thats fantastic, you don't need to respond as I'll mark it as resolved. If you have any further questions then please feel free to respond or open a new thread. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.