Manually Add Students Only Is Not Functioning As I Would Expect

I have a course set with the value Manually added only under the option Who can enroll. However, when an non-enrolled student views course information they are given an Enroll Now button AND when that button is pushed they get a congrats pop up as seen in the attached image. Shouldn't the Manually added option prohibit people from adding themselves to the course? Sorry attached the wrong image ... in any case, students can enroll themselves and that seems wrong based on this setting.

  • Michelle Shull

    Heya, Christopher!

    I just checked your site as a visitor, and I'm not seeing an enroll button, so that's good.

    Were you by chance logged in with your own (admin) account when you were able to see the Enroll button? If so, that's expected behavior.

    If you weren't using you own account, would you mind letting me take a look under the hood so I can try to replicate this as a member of your site?

    If this is ok, just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    If you have not installed WPMU DEV Dashboard plugin yet, kindly do that here : https://premium.wpmudev.org/project/wpmu-dev-dashboard/ and then allow access as per the above process.

    Thanks, Christopher!

  • Christopher

    Thank you VERY much. I just provided Support Access through the dashboard.

    One thing I would like to clarify is that I was logged in ... as a user ... but NOT as an admin. The user name was vanoosterhoutc (added in WordPress as a subscriber). When I added them as a WordPress account does that mean that they automatically can add themselves to any course . . . even courses with manual add only in the course set up?

    If you would like (if support access does not allow it), I can set up another subscriber account for you or give you access to the vanoosterhoutc subscriber account I was using.

    Thanks again.

  • aristath

    Hello again @Christopher,

    I tried accessing your site yesterday and today but was unable to... Perhaps something in your server's configuration is preventing us from automatically accessing it.

    Can you send me your admin credentials please?
    - Send an email using our secure contact form on https://premium.wpmudev.org/contact/
    - Select "I have a different question" from the dropdown
    - On the subject enter "Attn: aristath".
    - Include the URL of this post in your message so that I may track this issue
    - Include a link to your website
    - Include your superadmin credentials (username + password)

    Cheers,
    Ari.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.