Manually change user to memebrship admin in wp_usermeta table wp_capabilities

I had a problem with my account being reset, andhsad to go into the db and change my admin account manually. I had to overwrite the settings that made me a membership account manager as well in wp_usermeta for wp_capabilities.

Now membership doesnt show up in the dashboard, and I cannot figure out how to put the settings back in. Is there a manual way to do this? I have membership set up about as good as I can get it (except for the mailchimp ping problem) and would hate to have to reconfigure all this.

  • Patrick

    Hi there @Sean

    I hope you're well today!

    By default, the Membership plugin will display only for the user who installed it.

    So, what you can do is delete the Membership plugin via FTP (or File Manager in your cPanel).

    Do not delete anything in the database.

    Then, logged into your site as your new admin username, upload the plugin again and activate it.

    You should then have full access to everything, and all your settings will still be there.

    Also, if you're using the WPMU DEV Dashboard plugin, be sure that your new admin user is also the one who installs & activates it. Otherwise, you'll need to manually update your premium plugins from WPMU DEV.

  • Sean

    Awesome. I just fixed this another way... the long way around. I set up memebership on a new site temporarialy. Then I copied the wp_usermeta element for the capabilities, and then copied it over to the problem child. It looks like it works, however if I need to I will do what you suggest. Thanks!

    Here is my data I posed in case it helps. It is the admin for the site and the membership admin in the wp_usermeta and the capabilities value for the ADMIN user only.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.