map is not responsive

the map is not responsive and i don't see the geolocation with the mark you are here.
Also on the icon i have write something in the body and it is not displayed .
I will open support also so it is ready if you need it.
Thanks a lot

  • Adam Czajczyk

    Hello Nicolas,

    I hope you're well today and thank you for your question!

    I have checked your site and once I allowed browser to track my position a marker has been added to the map on your site, see the screenshot below (this shows correct location of me):

    It's important however that the visitor agreed to be geolocated by the site. If such such permission was denied previously "for good" ("never allow..." response) the map will not track location. Could you please make sure that you allowed that? It may be worth checking with different browser as well.

    As for map not being responsive.

    The shortcode that you added to your homepage includes map width and height. I didn't want to edit your site without permission so could you please try removing these attributes (at least "width" attribute) from the shortcode? If there's no width/height set explicitly the plugin should take care of map size adjustment.

    Let me know please if that helped and in case it didn't let me also know if I'm allowed to make changes to map settings/shortcode.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello nicolas!

    I checked your site again and this test actually helped me spot another issue there: there should have been used double-quotes (double-apostrophe) characters in shortcode while some of them got replaced with "traditional" quotation marks. It seems that this was breaking shortcode performance.

    I have tweaked that and also added the width attribute back and the map is now showing and seems to be responsive as it should. Please clear your browser's cache and check the site, I think it should be okay now.

    Just for future reference: when you are adding shortcodes to with Divi builder (to a Divi module) it's best to switch editor to a "text" view instead of "Visual" view as the latter one is sometimes messing with character encoding.

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.