Mapped domain breaks the Headway theme?

I've got a Wordpress multisite installed at ewprogram.com where we are using the Headway theme (http://headwaythemes.com/) for most of the subdomains that we create. Headway uses a separate visual editor within the Wordpress dashboard to allow users to adjust the template in all kinds of ways.

The problem I'm having is when I install Headway and then map a domain with the WPMU domain mapping plugin. Once I've mapped the domain, it breaks the link to the visual editor in Headway.

Here's an example to explain what I mean. I created a new site within the network (ewprogram.com/test). I installed the Headway theme and the visual editor now takes me to "http://ewprogram.com/test/?visual-editor=true" in order to use Headway. But then I mapped the subdomain davidmorgen.net onto ewprogram.com/test. Once that is completed, when I try to go to the visual editor it wants to bring me to the address "http://davidmorgen.net/?visual-editor=true" which returns a "Site Unavailable" error.

I thought that I could fix this by changing the settings in the domain mapping plug in. When I go to the settings page in my multisite dashboard, I have two options: administration mapping and login mapping. I've set them both to "original domain" and saved, but that does not seem to solve the problem.

Is there some way to keep the visual editor in Headway trying to go to "http://ewprogram.com/test/?visual-editor=true" even after I've mapped a different domain to "http://ewprogram.com/test/"?

(I don't know if this is helpful information or not, but when I initially set up the domain mapping plug in, I accidentally entered the incorrect IP address for ewprogram.com. I've since updated the plug in with the correct IP address. When I go to the domain mapping settings on the network administrator dashboard, it shows the correct IP address. But when users goes to use the domain mapping plug in on their subdomains, the settings page there is still showing the initial incorrect IP address in the instruction language at the top of the page. I've changed the IP address a few times and hit the save button and the confirmation says that the information has been updated, but the old IP address continues to show up in the instructions. Could it be that these settings aren't saving for some reason?)

Any help you can offer would be very much appreciated.

Thanks,
David