Mapped domain redirects to a page inside the site (not home)

Hi,

Now I've got a dedicated IP for my site (multisite network). This time I really do :wink: But domain mapping still doesn't work.

I'm using example.com. I set an A record with the IP of my site.

When you put this IP in your navigator you actually go to the site (on the homepage). But when you use example.com you're redirected to a page inside the site (not the homepage). This page is the one used by New Blog Templates (I'm using the New Blog Templates option "As a showcase inside a page").

I guess this is the reason why domain mapping doesn't work.

Any idea?

Best Regards

  • Arom77
    • Froggy

    Hi @Alexander Rohmann,

    This is indeed my signup page (this is the first page of the signup process, using New Blog Templates).

    I don't really understand what you mean... Here is a screenshot of the DNS area of example.com that shows what I did until now. What shall I do next? Thanks!

  • Arom77
    • Froggy

    Hi @Alexander Rohmann

    I think I figured out how to make Domain mapping work. I only set A records.
    For example, if I want to map sub.example.com to sub.mysite.com, I create a A record for sub.example.com with the IP of my site.

    That being said, I'm surprised to read this here:
    https://premium.wpmudev.org/project/domain-mapping/#usage

    CNAMEs are used for sub domain mapping. i.e. you want to map blog.userdomain.com to usersite.yourdomain.com

    A Records are for mapping TLDs aka Top Level Domains. i.e. userdomain.com mapped into usersite.yourdomain.com

    I map sub.example.com to sub.mysite.com and only use A Records. And no CNAME. Is this normal?

  • Alexander
    • DEV MAN’s Mascot

    Hi @Arom77,

    I'm sorry about the delay here. If you are redirected to the signup page after entering the domain, it usually means the DNS settings are correct, but that WordPress doesn't know which site to assign it to. It therefore requests a user to add a new site.

    Have you added the domain to a site yet? When adding it, be sure to not use www in the mapped domain.

    Best regards,

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.