Mapped Domain suffixes "/blog" and causes recursive redirect

I attempted to configure the domain mapping plugin to configure a multisite blog, http://whnlive.com/blog/omt as it’s own URL: http://liveox.com.

The Domain configuration page automatically suffixes “/blog” to the page -> http://liveox.com/blog/ Accessing this results in a redirect loop, hence I cannot utilize the the plugin. Other configuration values: Network redirect: OFF. Network DNS is not redirected (doesn’t work when it is either).

What cuases the inclusion of the “/blog” suffix when it is not specified? How can I set parameters to adjust for this? Is there a way to turn off the automatic suffix?

  • DavidM
    • DEV MAN’s Mascot

    Hi squibm,

    I couldn’t quite tell which was the sub-site you’re trying to map to. Is it whnlive.com/blog ?

    I think that would be a conflict with the fact of multisite using the ‘blog’ slug for your main site’s blog permalinks. You should see that slug in use in your admin for your main site at Settings > Permalinks. Do you have that slug there?

  • Mason
    • DEV MAN’s Sidekick

    Hiya squibm,

    The link you provided for Giving WordPress Its Own Directory specifically states (highlighted in red) that it will not work for Multisite. Domain Mapping is one of the many things that won’t work (by default) in this type of setup.

    We always recommend that WordPress Multisite be installed at the root domain first. It will make everything run more smoothly from there :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.