Mapped Domain using Multisite losing the www from the mapped domain

I have http://www.haitigospelfund.com mapped to our multisite wp installation and have an A record and “www” CNAME record set to the IP address of our domain. When I type the full http://www.haitigospelfund.com into the address bar, the site comes up, but without the www subdomain. Rather it just shows as http://haitigospelfund.com.

Is there anyway to get the full domain with the “www” to show up on the address bar?

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for posting on the forums.

    When I type the full http://www.haitigospelfund.com into the address bar, the site comes up, but without the www subdomain. Rather it just shows as http://haitigospelfund.com.

    www is not considered as a sub domain by default unless you have created a sub site named http://www.mainsite.com under your multisite installtion.

    I have installed WordPress on my lab site without www and no matter I enter http://www.maindomain.com or just maindomain.com, it will take me to maindomain.com

    However, as per the plugin settings If your domain name includes a sub-domain such as “blog” then you can add a CNAME for that hostname in your DNS pointing at this blog URL.

    I hope that helps. Please feel free to ask if you have more questions on the same.

    Cheers

  • Timothy
    • Chief Pigeon

    Hello, hope you’re well!

    How’s things going now, we haven’t heard from you in a short while and as such he thread became marked as “Resolved”.

    If you’re still in need any help then please feel free to reopen or create a new thread as needed for any issues.

    Cheers.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.