Mapped site is not loading in the front

I am having some issues with domain mapping. I have my domain registered on godaddy.com. I have changed the DNS setting of 'A' to the the IP address of my multisite's dedicated IP as suggested.
Now I have the domain added in the subsite but when I load the mapped domain in the front it is showing "server IP address could not be found."

  • jnkfrancis

    Hi Alim,

    I hope you are doing well. I took a look at your site and there are a few things we can do to get everything working for you.

    First up, the domain you put in for your domain mapping has a typo. You have vpwards.com and the domain that points to your ip is vpawards.com (you're missing the first "a").

    That is the easy fix and will go a long way.

    Next up I noticed in the chat that you wanted to have requests for pages not on your network, not go to the registration page. That can be accomplished with a quick addition to your wp-config.php file.

    define( 'NOBLOGREDIRECT', 'https://fourplusmedia.com' );

    You will need to login to your site via ftp or through your host's file manager and edit your wp-config.php file anywhere above the /* That's all, stop editing! Happy blogging. */ comment. You can change the site URL in that code to any page you want to redirect them too. So you could redirect them to a simple site not here page, a coming soon page, or even to a sales page of some sort. That code right there will just direct them back to your home page.

    Also, I noticed that you have your multisite open to registrations. If that is what you want, that is fine however if that is not your plan, having your site open to registration could open you up to spam. To disable Registrations you will want to go to Network Admin > Network Settings and then select "Registration Disabled". Like I said this is totally optional.

    Next up it is very important to make sure that you have the latest version of sunrise.php active.

    This procedure is very simple and all you will need to do is access your site via FTP or through your host's file manager, as you did earlier, and move the file from within /wp-content/plugins/domain-mapping/ to /wp-content/.

    It is very important to be sure that you keep your plugins and files updated to the latest version not only for compatibility and performance but also for security.

    That said it is highly recommended that you update all of your plugins and themes, including Domain Mapping. That will give you the best chance for all of your plugins to be compatible and work properly together.

    That should get things on track for you and if you have any questions please let us know.

    Jeremy

  • jnkfrancis

    Hi Alim,

    I hope you're having a great day. It looks like the problem was that you had some code in your wp-config.php file that was after the

    /* That's all, stop editing! Happy blogging. */

    It is very important that when you edit your wp-config.php file that any edits are above that line. I moved the code above the stop editing line and everything seems to be working as expected. I saved your old wp-config.php file as wp-config-10-27.php in case you need it for some reason.

    Let us know if there is anything else we can help with.

    Jeremy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.