Mapping my domain

ok - I'm not sure this plugin is doing what I want it to do, maybe I set it up wrong.

I have my multiuser site.
An "extension blog" has been setup up for my "Blog A".
Blog A, existed with the URL "blogA.com"
Now I want the new extension bog of my WPMU site to be the new homepage of the "blogA.com" URL.
So I have tried to use this plugin.

I have configured the plugin with my servers (my sites) IP.

I have setup this plugin in my new extension blogs setup with the URL of the existing website that I want to move ie: "blogA.com"

now all this plugin does is link to my old blogA.com url, this is not what I was expecting.

(I was expecting that if I now type in "blogA.com" it would direct me to my new extension bog.

Do I have to setup (point) my blogA.com URL from it's hosting service to my new WPMU IP address as set up in this plugins config?

I started doing this, but my host (hostmonster) requested that I entered a primary AND SECONDRY IP address for this to take effect. I don't know what the secondry address is that I should put in.

Am I doing this wrong?
What is the secondry IP I should enter?
Help?
Please?

  • hkcharlie

    Like the title of my topic suggests, I am looking for support "Mapping my domain" and I am trying to do this with your plugin which is called "Domain Mapping".

    Here "extension blog" is used to mean "not the main blog" of my WPMU site, does it have an official name? Site? Which could easily be confused with, "my website", I don't know.

    so, let me explain another way for you:

    1. I have a wordpress site called "www.icantvaevunud.com"
    2. I have WPMU site called "www.seeonallmul.com"
    3. I have made a new blog on "www.seeonallmul.com" called "www.seeonallmul.com/icantvaevunud/"
    4. I am trying to use your plugin called "Domain mapping"
    5. I want the URL "www.seeonallmul.com/icantvaevunud/" to be accessed by the URL "www.icantvaevunud.com"
    6. I have configured the plugin in "www.seeonallmul.com" and "www.seeonallmul.com/icantvaevunud/"

    what are the next steps I need to take to make this work?

  • Mason

    Hey hkcharlie,

    It sounds like you've almost got it, but I'm trying to get caught up so bare with me a moment and I'm sure we can get this figured out.

    First off, is this correct?
    You have 3 Blogs with WordPress:
    1. http://www.icantvaevunud.com - WordPress
    2. http://www.seeonallmul.com - WPMU
    3. http://www.seeonallmul.com/icantvaevunud/ - a sub blog of your WPMU site

    You've installed Domain Mapping on #2 and #3.

    You're wanting to map the blog from #3 to the URL in #1.

    Assuming all this is correct, it is very doable and you're very close. I'd like to first make sure that we understand that the WordPress install on #1 will no longer be visible once you've made these changes. It will cease to exist and you can delete/uninstall it.

    Have you made the DNS or "a record" changes for the URL #1?

    Have you un-commented the sunrise.php line in wp-config.php?

    Here's some installation instructions to look through:
    https://premium.wpmudev.org/project/domain-mapping/installation/

    *Note where it mentions "parking" your new domain. If you're using cPanel, this is best.

    On domain #1, you need to edit its DNS settings to actually point to your server IP or CNAME or whatever you do to make the domain connect to your server. For me, I just give it a new A record with my server IP in it. Easy.

    There may be more to it than just that, depending on your host. Every host is different, and you’ll have to talk to your host to make them able to point the domain name at your existing site. How to do this varies from host to host, but the important thing is that when you visit your new domain (before you do this!) then you want it to go to your main site, as is.

  • hkcharlie

    You are exactly right in your understanding of what I want to do with all these sites.

    Have you made the DNS or "a record" changes for the URL #1?
    I use hostmonster, it appears to me that their are two DNS settings that I need to input.
    When you say changing the "a record" do you mean that I need to set the first one to the DNS as stated in for my root blog AND copy the second (I gues "b record") as is for the new DNS setting?

    Neither you or my hosts (hostmonster) have made any comment about this second DNS. They say ask you about this second DNS and I'm waiting for you to say, ask them about this second DNS record.

    Have you un-commented the sunrise.php line in wp-config.php?
    Yes I have, as per the install instructions.

    Thanks for your help mason james!

  • Mason

    OK, for domain #1 above:
    You can either put in the IP address of your server (as defined in your domain’s main A record) or you can put in a CNAME that points to your server. The IP address is what I would recommend you to use. If you're unsure of how to do this, google "change domain a record" and add your specific host or registrar for this domain. There's tons of specific info on this.

    Also, your multisite install (#2) is hosted with hostmonster? Do you have access to cPanel?
    If so, from Cpanel, click on the “Parked Domains” under the “Domains” section:
    1. Under “Create a New Parked Domain” enter the domain name you want to add to your network.
    2. Click the “Add Domain” button.
    3. It should add the domain to the list of parked domains and under “Redirect to” it will say “not redirected”. That is OKAY.

    If the above two things are correct, you should be in business.

  • Control Yours

    I'm Having trouble with appropriate Domain Mapping settings.

    -Wordpress V. 3.0 Multisite
    -My root site (http://threespeak.com)
    -My sub directory (http://gracopack.threespeak.com) - Trying to map the domain 'gracopack.net'
    -Using 'cheapcheapdomainnames.com' (same interface as godaddy)
    --I've Changed the DNS A Record to my ip address of server.
    -I've 'Parked' my domain using CPanel on my hosting account (hostgator.com).
    -I've made sure the 'sunrise.php' is in the right location (wp-content) and that the code [ define('SUNRISE','on'); ] without brackets is in the wp-config.php

    and it's still not working for me...I can't figure it out. It's taking me to a landing page...
    Do I need to change my name servers in the domain settings pannel? Currently it's set on the 'park' setting with default name servers:
    NS03.DOMAINCONTROL.COM
    NS04.DOMAINCONTROL.COM

    I would love some help, thanks a bunch in advance!
    Chais

  • Mason

    Hiya Chais! Welcome to WPMU DEV.

    You could definitely use the name servers if you like. Just change the settings in cheapcheap... to "I have specific nameservers for my domains." and change the nameservers to the one from your cPanel information. Also, just to be sure: have you gone into the domain mapping section in wordpress and set it up within there?
    You need to go to Super Admin>Options and scroll down to "Server IP Address" and enter in the IP address from cPanel, then go to your subdomain site and find the domain mapping section there. Should be under Tools>Domain Mapping. There just enter in the domain name (gracopack.net in your case) and it should all be up and running. Let us know if you need anything else and again, welcome!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.