Mapping re-directs

When using WPMU and the WPMUDEV mapping plug-in, what's the best way to redirect the ancillary ".org" and ".net" to the primary ".com" address which is in turn mapped to "blog1.mydomain.com"?

I've acquired a new .com, .org, and .net domain name. I'll call it "site1.com". I have parked and configured site1.com so it now properly maps to blog1.mydomain.com. So far so good.

The site1.org and site1.net variants have also been parked and set to forward to site1.com. However, when I test the site1.org and site.net forwards, they default to my primary site blog page at mydomain.com, not the desired site1.com page at blog1.mydomain.com.

When setting up forwards for alternate addresses, do they also need their own mapping or should I change the forward to point a the desired blog page rather than the .com address?

  • Timothy Bowers

    Hey there.

    When using WPMU and the WPMUDEV mapping plug-in

    So you're using two different mapping plugins?

    what's the best way to redirect the ancillary ".org" and ".net" to the primary ".com" address which is in turn mapped to "blog1.mydomain.com"?

    You shouldn't redirect here, you just need to direct them to your install.

    So if it's a client and they need to manage their own DNS (don't wish to give control of their DNS and things like MX Records for email) then they should make their A Record go to your WPMU install.

    You need a dedicated IP for this and it's DocumentRoot must be your WordPress install.

    The other options are using them as Addon or Parked domains (cPanels names, other control panels may have other names for this), again their DocumentRoot must be your WordPress install.

    The site1.org and site1.net variants have also been parked and set to forward to site1.com. However, when I test the site1.org and site.net forwards, they default to my primary site blog page at mydomain.com, not the desired site1.com page at blog1.mydomain.com.

    Under the mapped site which is working you will have added site1.com to the Domain Mapping area right?

    Admin --> Tools --> Domain Mapping

    But the other two are not right?

    That's normal behaviour, you can add the other two though by adding this to your wp-config.php file:

    define('DOMAINMAPPING_ALLOWMULTI', 'yes');

    Add it directly below where you put the sunrise constant if you wish.

    Then in:

    Admin --> Tools --> Domain Mapping

    You can now add multiple domains.

    Why wouldn't I want to do this?

    - It won't benefit you in Google
    - Google will see that content is duplicated because it will be the same on all those domains. This could affect your SEO
    - It's a waste of a domain

    What should I do?

    If you really want them to all be the same site, then just forward them to site1.com, then Google will see that a normal redirect and use the .com as the site.

    But you paid for those domains, so another option would be creating two more sites within the multisite and put some unique content on them. Use the same theme if you wish so it looks uniformed. Even share a similar Nav if you wish so they can move from one to the other.

    This way there there is no duplicate content and Google will be cool with that.

    When setting up forwards for alternate addresses, do they also need their own mapping or should I change the forward to point a the desired blog page rather than the .com address?

    Do you want them mapped for SEO? i.e. so that search engines will index them as their own domain?

    If so then do as I mentioned above.

    If you're not so fussed then just forward them in cPanel to wherever you wish.

    Take care.

  • Temporal Sales

    So you're using two different mapping plugins?

    No. Poor wording on my part. I'm just using the WPMUDEV mapping program.

    Under the mapped site which is working you will have added site1.com to the Domain Mapping area right?

    I'm sorry, let me start again from the top.

    (1) All the domains in question are "mine", not someone else's or associated with someone else's site.
    (2) All the domains are parked on my VPS and I have full control over the DNS, cPanel, etc. (although my hosting service helps me a lot.)
    (3) I'm in the process of setting up an WPMU network and I'm using MPMUDEV products exclusively, including the mapping plug-in.
    (4) My primary WPMU site and the mapping plug-in are working normally.
    (5) My new domain name, "site1.com" is parked and is mapped to "blog1.mydomain.com". This part of the set-up is working as it should.
    (6) I have also acquired and parked "site1.org" and site1.net" on my server just so no one else can acquire and use these domain names.

    What I want to do:

    All I want to do is configure site1.org and site1.net so that they simply redirect the user to site1.com (which is in turn mapped to blog1.mydomain.com.) I'm not trying to set up duplicate sites, jazz the search engines, etc.

    If you really want them to all be the same site, then just forward them to site1.com

    That's what i was trying to do. In cPanel under "forwarding domains" I typed in that site1.org should forward to site1.com. But in testing the forward it takes me to the blog page on my primary WPMU installation, not site1.com or its respective blog blog1.mydomain.com.

    Thanks!

  • Timothy Bowers

    Hey there.

    All I want to do is configure site1.org and site1.net so that they simply redirect the user to site1.com (which is in turn mapped to blog1.mydomain.com.) I'm not trying to set up duplicate sites, jazz the search engines, etc.

    If it's just redirecting them then I'd do that in cPanel so it simply forwards them to the site you wish.

    That's what i was trying to do. In cPanel under "forwarding domains" I typed in that site1.org should forward to site1.com. But in testing the forward it takes me to the blog page on my primary WPMU installation, not site1.com or its respective blog blog1.mydomain.com.

    Is it sending it to the main site like it wants you to create another sub site?

    Can I see a screenshot of how you set the forwarder in cPanel please?

    Take care.

  • Temporal Sales

    Is it sending it to the main site like it wants you to create another sub site?

    It's taking me to my main site, but just the blog page, not one that asks me to set anything up. In the first snapshot, I typed in http://angelsscrapbooking.com, which is redirected to http://angelscrapbooking.com.

    It takes me to my main site at temporalsales.net and the default buddy press theme rather than to angelscrapbooking.com with its grid theme.

    Can I see a screenshot of how you set the forwarder in cPanel please?

    See the second attachment.

    Thanks!

  • Timothy Bowers

    I have yes, what I've been doing is testing changing the redirects. For example one I sent to Google but yet that never works.

    I was giving it time just in case the DNS needed some time to resolve. Really changes shouldn't take this long to update but still...

    It seems it's still not changing so there has to be some config issue there.

    I just made another change and will give it a few to update again just in case it needs it.

    I reckon that there is a DocumentRoot defined for them and it's not being updated as it should. So a chat might be needed with your host.

    I'll be in touch. :slight_smile:

    Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.