Maps with Traffic Issue

When attempting to setup Google Maps with a traffic overlay, the map shows grey until you move it by cursor. Then, it is slow, doesn't load the entire map, the buttons have missing graphics. I have tried everything that I can think of to repair the map to no avail. I would appreciate assistance with this issue.
URL: https://coconinopost.com/traffic/

Thank you.

  • Adam Czajczyk

    Hello Leo,

    I hope you're well today and thank you for your question!

    I checked the site and at first glance it looks to me like it was either insufficient memory limit set for WordPress or something is "blocking" the maps. Could you start with checking and raising memory limit then?

    To do this, please follow these steps:

    1. Go to the "WPMU DEV -> Support" page and click on "System Info" button
    2. Inside PHP tab look for value in "memory_limit" line and note it down
    3. Switch to "WordPress" tab and scroll the page all the way down
    4. Check the value in "WP_MEMORY_LIMIT" line (not to be confused with "WP_MAX_MEMORY_LIMIT"!) and if it's any lower than the one you noted down in step #2, add this line to the "wp-config.php" file:

    define('WP_MEMORY_LIMIT', '256M');

    where 256M should be replaced with the value noted down in step #2 above; make sure that the line is located above the "/* That's all, stop editing...*/" line.

    After that, clear cache on site (if there's any caching plugin installed) and in browser and check the map again.

    Let me know please if that worked! If it doesn't could you please grant me a support access to your site so I could investigate it closer? To do this, follow this guide:

    https://premium.wpmudev.org/docs/getting-started/getting-support/#chapter-4

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Leo!

    Thank you for granting support access.

    I checked the site and it seems that your WP is still running on 40M of memory. The "WP_MAX_MEMORY_LIMIT" is set to 256M but not "WP_MEMORY_LIMIT":

    Since I was able to check the site I see that PHP can "offer" up to 256M so please double-check that this exact line (as suggested in my previous post) is added to the "wp-config.php" file of your site

    define('WP_MEMORY_LIMIT', '256M');

    The line must be located above the "/* That's all, stop editing...*/" one.

    The basic difference between WP_MAX_MEMORY_LIMIT (that is currently set to 256M) and WP_MEMORY_LIMIT (which is still set to only 40M) is that the latter one actually limits an amount of memory available to WP on front-end. That's why it's important here.

    The second potential culprit here might be caching. For now I tried to exclude /traffic/ page from cache but that might not be enough. Therefore if a memory limit solution doesn't help, try purging and disabling cache entirely for test. If that helps, I'll then further investigate cache settings. Otherwise, we'll need to dig a bit deeper so let me know about results of these two steps described above first, please.

    Kind regards,
    Adam

  • Adam Czajczyk

    Hello Leo!

    I assume that because that didn't work for you, you have removed that memory raising line and enabled cache back on the site, right?

    It looks like that would require some closer check. Would you mind letting me access your site directly so I could debug it and see what might be causing the issue? To do this, please send in:

    Subject: "Attn: Adam Czajczyk"

    - Mark to my attention, the subject line should contain only: ATTN: Adam Czajczyk
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - login URL and admin account login credentials (may be a temporary admin account) data
    - Include FTP log-in details (hostname, username & password)
    - Include hosting control panel access details (login address, username & password) - cPanel's usually the control panel used for this, but your provider may use something else; I'll need this for accessing your site's database, preferably via phpMyAdmin
    - Include any relevant URLs for your site

    Please use our contact form here https://premium.wpmudev.org/contact/#i-have-a-different-question

    Kind regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.