Market Press - Admin Email

Hey

Im still having problems getting a 'new order notifications' from my site to the store admin address. Ive tried a few things but I dont appear to be receiving them.

I have entered the Store Admin Email, entered, removed, replaced and tested, still not working.

The customer messages work so am I missing something here?

Cheers

Stephen

  • aecnu

    Greetings Stephen,

    I have tested this inside and out and I get the following email from Market Press after placing an order:
    ************************
    A new order (597078486f94) was created in your store:

    Order Information:
    Items:
    Product 2: 1 * 0.00 = 0.00 USD
    Download: Removed for security purposes.

    Order Total: 0.00 USD

    Shipping Information:
    No shipping required for this order.

    Email: Removed for security purposes.

    Payment Information:
    Payment Method: Manual Checkout
    Payment Type: Array
    Transaction ID: Array
    Payment Total: 0.00 USD

    Your payment for this order is complete.

    You can manage this order here: Removed for security purposes.
    ************************

    Therefore I have decided to dig in a bit as to why you are not receiving these as you should be. However, after digging there does not seem to be much that can go wrong if the email address is valid.

    Of course I am referring to the email address located at site dashboard --> Products --> Store Settings --> Messages --> Store Admin Email

    Can you please check your hosting server logs to see if there is an errors indicated?

    Please advise.

    Thank you for being a WPMU Dev member!

    Cheers, Joe :slight_smile:

  • aecnu

    Greetings Stephen,

    Thank you for sharing that with me and it is something I did not consider, nor heard of anyone doing before.

    This is not a good idea for the store site since it will be sending the emails directly from the Market Press plugin whereas if clients put there own email addresses in there to get the emails and there is no way to authenticate your email outbound through Google Apps --> there is the crux of the problem.

    The store has no way to authenticate outbound emails through Google Apps and that is why it does not work.

    Cheers, Joe :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.