Marketpress broken in more ways than one.

Ok, I had a problem(still do) with a product I purchased off this site. It seems to get customer support we have to pay even more. It's like ford selling me a car where the wheels don't work and then asking me to pay more to get it going! Anyway, rant over. I need help.

My Marketpress is installed on a Multisite and on one site it works and on another it does not.

The two sites are on a global cart. Plugins are almost identical and when I disable all the plugins on the one that doesn't work the fault is still there.

Ok the fault:
On checking out the last checkout on teh shipping page does not go to Paypal but recycles on itself. i.e. it stays on the same page going nowhere. On the site that works with exactly the same cart full of product it works fine.

I am sure it is something silly.
site one:
http://sonneteer.co.uk/home/
site two:
http://sonneteer.co.uk/home/boutique

one not working, two is working.

HELP!

  • PC
    • WPMU DEV Initiate

    Hey there Haider,

    Greetings and thanks for posting on the forums. Sorry to hear about your issues.

    The only difference in ford and us is that we sell plugins that work everywhere :slight_smile:

    Coming on to the issue, it seems like some issue with your .htaccess causing the weird redirect.

    Can you kindly post the contents of your .htaccess files from both sites ?

    The one that works and the one that doesnt. So that I can compare them and assist accordingly.

    Please advise.

    Cheers, PC

  • haider
    • Site Builder, Child of Zeus

    Thanks,

    working one:
    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php

    Not much there.

    Non working one:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /home/
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

    i hope this is helpful

    Haider

  • PC
    • WPMU DEV Initiate

    Hey there,

    Sorry but I am confused with

    They are both on the same Multisite if that helps.

    I am not sure how you have 2 different .htaccess on a single multisite.

    Can you kindly elaborate a bit about your setup ?

    They are 2 subsites on your WordPress Network Site ?

    Or are they installed on 2 separate WordPress installs ?

    I would love to have a closer look to see if that helps me understand the issue.

    Can you please send me your login details via our secure contact form

    1: Mark the email to my attention

    Attn: PC

    2: Include a link of this thread in the email

    3: Include FTP and WordPress super admin details.

    4: While filling the form, select "I have a different question" from the list.

    Looking forward for a response on this.

    Cheers, PC

  • haider
    • Site Builder, Child of Zeus

    Hi PC,

    Sorry for the delay. Just tried it and still not working. You can also try form your end as you simply don't need to complete the sale to see if it works.

    Thanks for trying. Any other possibilities?

    Haider

  • haider
    • Site Builder, Child of Zeus

    Hi PC

    is there anything I can do at this end?

    The problem here is we are potentially losing custom here. Luckily a customer called to inform us of the problem. What of all the customers who have simply given up?

    It is a grave concern that you seem to have only one developer of a product that is crucial to a business that adopts it. I understand he is away. Should he not have a deputy? or even better, a team of developers? We can't have a product like this fall down at the busiest time of year. This is suicide!

    I was forced to pay for a years subs just to get support and really, as much as I know you are trying to help, it is not satisfactorily forthcoming. Forgiveable(almost) if this were a cheap solution, but over time it certainly is not.

    Desperately waiting for a cure please.

    Haider

  • PC
    • WPMU DEV Initiate

    Hey there Haider,

    Thanks for your posts.

    Sorry for the delay however multiple posts form you will only make the response times higher I am afraid.

    We use feed readers to answer threads and whenever there is a new response, the time stamp is reset and it goes to the bottom of the feed.

    Coming to the issue, I tested the site closely and found that there are a lot of plugins that are not updated to your latest WordPress version which might be cause of the issue.

    You have also added custom addons to MarketPress plugin which might cause the issues too.

    Can you kindly disable all other plugins (including the custom addons) and switch the site to default WordPress theme (2013) on both the sites so that we can ensure that its not a plugin conflict or a theme issue ?

    Also, do you see anything in the server error codes ?

    Please advise.

    Cheers, PC

  • haider
    • Site Builder, Child of Zeus

    HI PC,

    I will try again, but I have already done all of this as per my original thread post. All plugins were disabled. However the other site that does work has the same plugins and works fine. They share an WP install on Mutisite too.

    I will see how I can change the themes without disrupting business. I was going to put in a workaround short term as it is really not a good time of year to be offline business-wise. Also most of my pages are plugin data only. So changing theme means rebuilding a bit.

    I was going to forward the the original cart call to the working site as it is a global cart, for now. This way at least customers don't just see a failed purchase and walk away.

    I need to think what is best for business in the short term as my time is tight right now. If so I will leave it hang till after the holidays. That is assuming the workaround works!

    Then I will wait to see if any other possibilities are found before I try switching everything again. I have noticed a few other people on other threads have exactly the same problem. So this is not unique to me clearly.

    Thanks,
    Haider

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.