Marketpress Categories still not working

Fullwidth theme

ADD NEW PRODUCT> Select the category. Not all categories are registering.

When you view the product it shows that the category is selected but when you click on the "category tag" that is displayed with the product(Screenshot1.) It directs you to the correct search page and that product is NOT there (Screenshot2.)

Thus, the product will NOT be in its designated category ... I've done everything...re named category slugs, deleted and added them again in all shops, cleared cookies and cache, re-freshed shops and categories... I am at a loss. I am not sure how to fix this issue.

I've been inquiring assistance about this for a few days and am on a deadline. Please advise with some follow through. I'm at a total loss on how to fix this? I've attempted everything that I know how to do to solve the issue. :disappointed:

  • Hoang Ngo
    • Code Slayer

    Hi @veggie,

    I'm really sorry about your issue.

    As i seen, it's seem have conflict with another category, but at this point i can not tell you much.

    Can you please grant the support access via our WPMU DEV dashboard so i can take a look deeper ?

    Best Regards
    Hoang

  • Hoang Ngo
    • Code Slayer

    Hi @veggie,

    I will need your cpanel and phpmysql for deeper go, can you please provide me via

    - Mark to my attention - ATTN: Hoang Ngo
    - Link back to this thread
    - Include cPanel (I will need to look at the DB so need PHPMyAdmin or similar)
    - Include FTP
    - Include any relevant URLS for your site

    On the contact form, select "I have a different question", this ensures it comes through and gets assigned to me.

    Best Regards
    Hoang

  • Hoang Ngo
    • Code Slayer

    Hi @veggie,

    I hope you are well today and I'm sorry about the delay.

    I has update the product that's link to the category jewelry, and now it is working :slight_smile:

    If you have any issues please don't hesitate to let us know so we can assist

    Best Regards
    Hoang

  • veggie
    • Site Builder, Child of Zeus

    @Hoang Ngo it's not just the jewelry category... It's all of the categories randomly.... If a product has about five categories selected marketpress will not register all of the categories... The category tag Will show as selected on the product page but if you click to look in that category the product will not be there.... There is something malfunctioning. Sometimes the product is in the category but sometimes it's not... For another example you can text a product and try to add it in five different categories. The look in all of those categories. You will see it is no working.

  • veggie
    • Site Builder, Child of Zeus

    @Hoang Ngo can you please look into this issue in depth. I have no clue why it's happening.... I cannot launch the site until this is fixed. Thank you... It's a bigger issue then just that one category. You will see what I'm saying if you Add a test product and check a few categories... It will not function correctly.

  • Hoang Ngo
    • Code Slayer

    Hi @veggie,

    I hope you are well today and I'm sorry about the delay.

    I has been working on your site many days, but I still not reprocedure the same issue on my test site.

    One question, does your MarketPress plugin has been modification, and if yet, how much it is, i need more info so we can resolve this issue quickly :slight_smile:

    Best Regards
    Hoang

  • veggie
    • Site Builder, Child of Zeus

    @Hoang Ngo every single time I add 5 categories to any product this issue happens for me.

    Also it is happening to your product that you created... as you can see you selected a few categories for your product and when you click the tags for the product it only shows up in one category....The screen shots will show what I am talking about.

  • veggie
    • Site Builder, Child of Zeus

    @Hoang Ngo as you can see from the screen shots your test product is only showing up in the "art books" category not all of the categories selected. This is a problem. This is happening even with your test product. This is happening all over the site. The issue is occurring...do you understand the issue? Please advise.

    Yes, my marketpress.php is edited.

    Here are the lines of codes that are taken out of the marketpress.php

    change marketpress.php file (((DELETE THIS))))

    <div id="mp_product_link_div">
    <label title="<?php _e('Some examples are linking to a song/album in iTunes, or linking to a product on another site with your own affiliate link.', 'mp'); ?>"><?php _e('External Link', 'mp'); ?>:
    <small><?php _e('When set this overrides the purchase button with a link to this URL.', 'mp'); ?></small>
    <input type="text" size="100" id="mp_product_link" name="mp_product_link" value="<?php echo esc_url($meta["mp_product_link"]); ?>" /></label>
    </div>

    <tr>
    <th scope="row"><?php _e('Force Login', 'mp') ?></th>
    <td>
    <?php $force_login = ($this->get_setting('force_login')) ? 1 : 0; ?>
    <label><input value="1" name="mp[force_login]" type="radio"<?php checked($force_login, 1) ?> /> <?php _e('Yes', 'mp') ?></label>
    <label><input value="0" name="mp[force_login]" type="radio"<?php checked($force_login, 0) ?> /> <?php _e('No', 'mp') ?></label>

    <span class="description"><?php _e('Whether or not customers must be registered and logged in to checkout. (Not recommended: Enabling this can lower conversions)', 'mp') ?></span>
    </td>
    </tr>
    <tr>
    <th scope="row"><?php _e('Product Listings Only', 'mp') ?></th>
    <td>
    <label><input value="1" name="mp[disable_cart]" type="radio"<?php checked($this->get_setting('disable_cart'), 1) ?> /> <?php _e('Yes', 'mp') ?></label>
    <label><input value="0" name="mp[disable_cart]" type="radio"<?php checked($this->get_setting('disable_cart'), 0) ?> /> <?php _e('No', 'mp') ?></label>

    <span class="description"><?php _e('This option turns MarketPress into more of a product listing plugin, disabling shopping carts, checkout, and order management. This is useful if you simply want to list items you can buy in a store somewhere else, optionally linking the "Buy Now" buttons to an external site. Some examples are a car dealership, or linking to songs/albums in itunes, or linking to products on another site with your own affiliate links.', 'mp') ?></span>
    </td>
    </tr>
    <tr>
    <th scope="row"><?php _e('Google Analytics Ecommerce Tracking', 'mp') ?></th>
    <td>
    <?php if ( MP_LITE === true) { ?>
    »"><?php _e('Upgrade to enable Google Analytics Ecommerce Tracking »', 'mp'); ?>
    <?php } ?>
    <select name="mp[ga_ecommerce]"<?php echo MP_LITE === true ? ' disabled="disabled"' : ''; ?>>
    <option value="none"<?php selected($this->get_setting('ga_ecommerce'), 'none') ?>><?php _e('None', 'mp') ?></option>
    <option value="new"<?php selected($this->get_setting('ga_ecommerce'), 'new') ?>><?php _e('Asynchronous Tracking Code', 'mp') ?></option>
    <option value="old"<?php selected($this->get_setting('ga_ecommerce'), 'old') ?>><?php _e('Old Tracking Code', 'mp') ?></option>
    <option value="universal"<?php selected($this->get_setting('ga_ecommerce'), 'universal') ?>><?php _e('Universal Analytics', 'mp') ?></option>
    </select>

    <span class="description"><?php _e('If you already use Google Analytics for your website, you can track detailed ecommerce information by enabling this setting. Choose whether you are using the new asynchronous or old tracking code. Before Google Analytics can report ecommerce activity for your website, you must enable ecommerce tracking on the profile settings page for your website. Also keep in mind that some gateways do not reliably show the receipt page, so tracking may not be accurate in those cases. It is recommended to use the PayPal gateway for the most accurate data. More information »', 'mp') ?></span>
    </td>
    </tr>

  • veggie
    • Site Builder, Child of Zeus

    @Hoang Ngo do you need anymore information? This is pushing back the launch of the site. I thought this would be something easy for marketpress to handle. As it is advertised to function in a multi-market environment. This should be a very simple function. Please let me know. Thanks :slight_smile:

    • Paul Kevin
      • Neo

      Hello @veggie,

      How are you today? Sorry for the late response and thank you for your patience.

      From your shop set up, I have seen that your are trying to display products from different categories across different sites. Have you enabled global categories that can be used and accessed across the sites?

      A custom solution may be needed to achieve this. Kindly share credentials for some of the sub sites for further investigation.

      If you need further assistance we are here to help.

      Regards.

      Paul Kevin

    • Paul Kevin
      • Neo

      Hello @veggie,

      I have had a chance to go through the theme you are using an I have noticed that you are also using functions from the inactive theme Pro3. Functions from an inactive theme will not be called unless it is in the active theme and this could be one of the reasons you are not getting the products to show. Did the product view work before on the Pro3 theme?

      Could you move the functions being used to a separate plugin for global use?

  • veggie
    • Site Builder, Child of Zeus

    @Paul Kevin I am sorry I don't understand how to fix this or test it. I deactivated the other theme and started using this theme. When deactivating themes I assume it 'deactivates' it. I was testing the other theme and switched to this one because of how it looks, they are made by the same person marketpressthemes.com. Should I delete all existence of the other theme? How can I fix this...? I really need a solution. Feel free to muck around on the site to fix this issue, I can recreate existing information, as this is stalling us going live. Please let me know...as soon as possible...

  • veggie
    • Site Builder, Child of Zeus

    @Paul Kevin as you can see... If you look at the product in the books. There is a product in 'creative books' but it is not listed on that test page... The product category is selected for the product and is displayed on the products page as a tag and selected but the product does not show up in that category if you click the "product category tag" on the product page...

  • veggie
    • Site Builder, Child of Zeus

    @Paul Kevin but marketpress is a functioning mutlisite platform from what I read. How can I make it function correctly. I set up categories all the same with repeating slugs and categories that duplicates using the 'new page template' ... So it should be working... What can I do? I need this to function for the site to actually run

  • veggie
    • Site Builder, Child of Zeus

    @Paul Kevin is that the issue? I have been changing a lot of the slugs around to try and fix this issue. Because at first I thought it was an issue with the slugs. But when I change them it still isn't working. Feel free to test around.

  • Jonathan
    • The Bug Hunter

    Hey @veggie,

    Ok, it looks like you're still using MarketPress 2.9.3.9 - you'll need to update to 2.9.4. I just tried doing this for you, but it looks like you your site is tied to a free API key instead of your paid API key so you can't get automatic updates. :slight_smile:

    You'll want to login to your network admin and go to WPMU DEV > Manage and update your info there. Once you do that you can update to 2.9.4 and your problem should be fixed.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.