marketpress category widget links takign to home page

The marketpress category widget doesn't seem to work. Whenever you click on a category it redirects you to the home page or if you are logged in to the members page. Any ideas how to fix this? Thanks!

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    Thank you for this great question and bringing this significant issue to our attention.

    After testing I found no issues with the Products Category widget in Market Press as shown on my test production server http://marketpress.aecnuwpmu.us/

    What theme are you using?

    Have you gone through standard troubleshooting protocol?

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting.

    You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    Cheers, Joe

  • Spiritap
    • Site Builder, Child of Zeus

    Hello!
    Thanks for the reply. I just tried disablling all plugins (both on network admin side and admin of the actual page) with no luck. I also changed to default wordpress theme and no luck. Any other ideas? Thanks!
    Aaron

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    Thank you for your additional feedback, it is certainly appreciated.

    I visited your store and figured out that something in your installation is indeed changing the slugs for the categories. Without being able to dig inside the following is what I found.

    Your current link to the categories hand made that does not work:

    http://www.light-links.com/marketplace/categories/hand-made/

    This is certainly not a Market Press slug above but the following is and it works:

    http://www.light-links.com/store/products/category/hand-made/

    And again:

    Not:

    http://www.light-links.com/marketplace/categories/services/

    Works:

    http://www.light-links.com/store/products/category/services/

    Please advise on what is changing the slugs?

    Cheers, Joe

  • Spiritap
    • Site Builder, Child of Zeus

    Hmm, interesteing. I couldn't find anything that would be changing that except int he marketplace settings I have the following for global marketplace url sugs-

    Marketplace base /marketplace/
    product categories /marketplace/categories/
    product tags /marketplace/tags/

    I tried to change the base to /store/
    and the categories to /category/

    but the links still didn't work. Any other ideas? As I said I disabled all plugins so I'm not sure what would be changing them. Thanks!

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    Thank you for the additional input, it is certainly appreciated and helpful in an attempt to resolve these issues.

    Have you tried resetting the permalinks after changing the slugs?

    You would not need to change the type of permalink, just clicking the save buttons should work.

    If that does not help we should then take a close look at the htaccess file where it should look like this if it is a sub domain install:

    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    The first four lines above are not relevant to the issue, they are a security item I add to protect the wp-config.php file from being hacked.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev Community Member!

    Cheers, Joe

  • Spiritap
    • Site Builder, Child of Zeus

    Hello,
    Sorry I've been tied up with other projects. I haven't had much luck figuring out what is causing those incorrect slugs. Where do I reset the permalinks in multisit? I can't seem to find them under settings anymore. Are they somewhere else?

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    Thank you for bringing this back into the light and for the great question.

    They are administered usually in each individual sites front end if not disabled by another plugin.

    Please advise if they are not present at all and be sure that you have not disabled them using a plugin of some sort.

    Look forward to hearing from you in any event.

    Cheers, Joe

  • Spiritap
    • Site Builder, Child of Zeus

    Hello, Yes I have that in there. I've tried these three and none seem to work-
    http://us5.api.mailchimp.com/1.3/?
    http://us5.api.mailchimp.com/1.3/
    http://us5.api.mailchimp.com/

    Attached is a screen shot. the apikey is my api kiey for the account with the "-us5" at the end and my id is the email list id

    I did check the api panel in mailchimp and saw this-
    11/26/2012 07:59pm
    nope ##my ip### listSubscribe json 0.604s WordPress/3.4.2; http://www.pa 1.3

    Thanks for the help!

  • aecnu
    • WP Unicorn

    Greetings Spiritap,

    Regarding the permalinks, they should be within the site admin dashboard, not the network admin dashboard under settings.

    However, if this is on the site with Buddy Press then I cannot find them there myself.

    Please advise if this is the case and if so I will dig in to find out how we can get them adjusted/reset.

    Cheers, Joe

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.