Marketpress checkout isn't handling tax correctly

When first testing the payment process there was a taxes line in the shopping cart. As can be seen in the screenshot the taxes line has disappeared. I've tried altering the store settings but nothing brings the taxes line back.

Any ideas?

  • Bigpawprint
    • WPMU DEV Initiate

    Hi Patrick

    Thanks for the help and the welcome.

    I've tried setting " Enter Prices Inclusive of Tax?" to yes and to no. The cart isn't working correctly in either case.

    I've selected flat rate shipping for United Kingdom. The cart wasn't working either before or after setting shipping.

    I need product prices to be displayed exclusive of tax with and tax to be displayed as a separate line in the cart.

    I can see that Marketpress does this as I have it working correctly on another multisite install.

  • Bigpawprint
    • WPMU DEV Initiate

    Hi Patrick

    I've just sorted the problem with your help.

    When posing as a test buyer I hadn't set the buyers address to United Kingdom so taxes and shipping were not applied. Your advice to set a shipping amount put me on the right path to discover my error.

    Many thanks for your help.

  • Patrick
    • Support Monkey

    @Bigpawprint

    You're very welcome!

    Glad we could figure this out. :slight_smile:

    I'm going to go ahead and mark this thread as resolved. If you still need more help on this, simply re-open the thread by ticking the Mark as Not Resolved (re-open) box below.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.