MarketPress Coupon not working

Hi there,

I am using MarketPress, selling online digital goods. I have a few coupons set up that were working for the past few weeks.

Now I went on to check on it and when I click on " Have a coupon code" in the check out page, nothing happens. The page does not change, or allow me to enter a code.

any advice?

  • aecnu
    • WP Unicorn

    Greetings ameade19,

    Thank you for presenting us with this significant issue.

    You may want to try recreating those coupons testing again and also doing a database repair if your host allows. The release of WordPress 3.4 has caused some things to go a little whacky.

    If you still have no progress fixing this issue, can we please have a link to the site where this issue is taking place?

    And a coupon code for testing too please?

    Cheers, Joe

  • Ella
    • The Incredible Code Injector

    Hi there,

    I also have serious problems with my coupon codes.
    The first (5 numbers) I made was not working, the second one (3 numbers) is working.
    But now i can not delete them....

    When i selected them and after that delete, i got the message that they are both deleted but they are still there and one is still working.

    What to do?

    Ella

  • Ella
    • The Incredible Code Injector

    Hi,

    I went with phpMyAdmin to the database, searched for the coupon code I used and found it in wp_options/ mp coupons. Deleted mp-coupons and my problem with the coupon codes who i could not delete was solved.

    After that I made four new ones, the first two appear in red on the screen. It was not possible to edit or delete them but they were working. The last two appear in green and I was able to edit and delete them.

    Don't think it is safe to use coupon codes...

    Ella

  • aecnu
    • WP Unicorn

    Greetings Alex and Ella,

    Thank you both for your additional input, it is greatly appreciated and helpful in trying to figure out what is going on there.

    Today I made coupons for both of you without and issues whatsoever as shown in my screen shot below using my Market Press test production site.

    I made one percentage and the other a set amount without error or issue of any kind. I wanted to vary things so I could replicate the issue, but to no avail.

    I tried varying the dates and the amount of uses, still works flawlessly.

    Therefore it is my opinion that it is time to go into full blown trouble shooting mode because it appears there may be some conflict there and one way to find out conclusively.

    Standard plugin trouble shooting protocol - first to switch to the Twenty Eleven theme just long enough to check for the problem - if the problem still exists next involves deactivating all plugins except the plugin in question and then see if the issue still exists.

    If it does not, then you want to activate plugins one at a time testing in between to see if the issue returns. Even when you find one plugin, it may be in your interest to deactivate the problem plugin and continue testing the rest of the plugins to insure no others are also conflicting. You will know the conflict when the issue returns and which plugin(s) you activated that cause the issue.

    Please advise if there are any plugin conflicts and if so what the plugins are that are conflicting.

    I look forward to hearing about your results one way or the other.

    Cheers, Joe

  • Ella
    • The Incredible Code Injector

    Greetings all,

    Switched all the plugins off and made 8 coupons. (screenshot)
    You see in the screenshot that the first 6 are red and after I created them it is not possible to edit or delete them.
    The first 6 coupons codes are starting with the number 1 ( 123, 1234, 12345, etc) You see that the names of the coupon code becomes (0,1,2,3 etc) The names are not the same as the coupon codes.

    The two green coupon codes (0123 and Ella1) have the same name as the code and it is also possible to edit and delete them.

    The only way to delete the "red" ones is phpMyAdmin and delete in wp_options mp_coupons

    But... "red" or "green" they are all working!

    So everything is working but don't start a coupon code with the number 1.

    Cheers

    Ella

  • aecnu
    • WP Unicorn

    Greetings Ella,

    Thank you for your feedback on this issue and showing us a potential downfall.

    Though I did not think to try to start a coupon with the number 1, this is still an issue the lead developer should know about and address.

    I have checked the change log for the recent release of Market Press version 2.6.1 and there is no mention of this issue being addressed.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • Aaron
    • CTO

    Interesting bug. It seems you just can't create coupons with a single numerical digit. And you are the first to try it seems :wink:

    I'll have a fix next version, probably forcing more than one digit as well. For now no problems though, just use a normal coupon code for testing and use.

  • Ella
    • The Incredible Code Injector

    Hi @Aaron,

    Almost good :slight_smile:

    It is not the problem with a single numerical digit but when the coupon code start with the number "1'"

    like: 123, 1234, 12345 etc. Then MarketPress gives a name as a single numerical digit.

    Ella

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.