Marketpress custom css file not working

i have made a custom css file in marketpress-styles and copied all default.css in there. But when I made changes to it they don't show on the frontend. Alle styling refers to the original default.css in the plugins folder..

Why is that? Do i need to manually include the new css file?

  • Predrag Dubajic

    Hey Kees,

    Hope you're doing well today :slight_smile:

    Can we first check that everything is created as it should be.

    First thing you need to do is create new folder inside your wp-content folder and name it marketpress-styles.

    After that create new CSS file inside that /wp-content/marketpress-styles/ folder and name it whatever you want, for example custom-mp.css.

    Once that file is created you need to edit it and on first line of that file paste this code:

    /*
    MarketPress Style: MyCustomCSS
    */

    You can change MyCustomCSS to anything you want.

    After that go to Store Settings > Presentation panel and there you should be able to select your new style, it will show as MyCustomCSS or if you used different name it will show like that.

    When you select that file the CSS code added inside it should be visible on front end.

    Let us know if you need additional assistance with this.

    Best regards,
    Predrag

  • David Thibault

    I'm having this same issue. I added the file, I see the new custom style as a selection in the Store Settings -> Presentation section. I set it there. Then I reload the front-end and if I go into the Chrome Developer Tools and look at Sources, that CSS file is not actually being loaded. Also, if I look at Console, there's no complaint that it failed to download any files. Note the screenshot that shows what loaded from the wp-content folder...no marketpress-styles folder at all.

    Please advise as to why it might be causing this issue.

    Thanks,
    Dave

  • David Thibault

    OK, as soon as I post I figured it out. I looked at your code (specifically lines like this):

    $theme_url = content_url( 'marketpress-styles/' . $store_theme . '.css' );

    and decided to try renaming my file from marketpress-styles/default.css to something else. I made the theme name match the file name and it started working. You should add to your documentation that a) you should not name your file default.css (because that also made the other default option disappear in Presentation settings) and b) make sure to name the custom theme name the same as the file name.

    Best,
    Dave

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.