MarketPress eCommerce 400 error when checking out

I am getting a 400 error when checking out.
Querry monitor is showing the following https://www.screencast.com/t/nojprDC9rfhn

  • Lindeni Mahlalela
    • Recruit

    Hello Thomas Edgell

    I hope you are doing great today. Thank you for reporting this issue to us and we are sorry for the inconvenience. I have accessed your website and I was able to replicate the issue.

    As reported by the Query Monitor plugin the issue originates from the UPS Shipping module. Basically, the error means the request sent to the API is not in the expected format. Maybe something changed on the UPS service and it expects some data not sent by MarketPress or something similar. Did this work before or its the first time you are trying it and it jut didn't work?

    If this worked before on your site then its probably a change in the UPS API which we will then find out exactly what changed so we can update the code in MarketPress. If it is your first time using this and it just doesn't work then its probably a bug we still need to find and fix. Please also note that the UPS Shipping module is still a Beta version and there could be some bugs.

    I am still investigating this and hope to find a solution soon, I have also asked for the developer's input on this, I will continue to investigate while I wait for his response and once I have feedback I will update again here.

    We really appreciate your patience with regards to this issue.

    Have a nice day.
    Lindeni

  • Lindeni Mahlalela
    • Recruit

    Hello Thomas Edgell

    I forgot to mention that the UPS API expects valid data to be sent to the API so in order to get the best response, please provide a valid address on the checkout form. If the address is wrong or some required fields are not set then the API may report it as a bad request because the expected data was not received.

    Thank you.
    Lindeni

  • Lindeni Mahlalela
    • Recruit

    Hello Thomas Edgell

    I hope you are doing great today. I had a confirmation from the developer that this is an issue with the change in API, we are working to fix this as soon as possible, but at this point I can not offer an ETA as to when this will be finished but I / someone else will update here once we have a fix even if the fix is not publicly released but we will make sure to update here or patch the plugin on the website.

    I hope you understand and thank you for your patience and feedback.

    Have a nice day.
    Lindeni

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.