MarketPress End Transaction Redirect

Once MarketPress completes a transaction it currently remains on the checkout page with nothing changed, cart remains full, no redirect to create a new account. This is the second issue with MarketPress I have had and I am being forced to hold off launching my site because of these issues. I am beginning to feel that my yearly subscription has become a waste. I REALLY want to love MarketPress but it is becoming a severe burden. Can someone take a look at this in depth and resolve these issues. If you need access to other pieces of my accounts please let me know (support) is already on –

  • Nastia
    • Support Rock Star

    Hello Kiley, I hope you are doing well today!

    I tested the Stripe gateway on my instllation and can’t recreate the same.

    Please make sure that you have created an Endpoint in Webhook settings? To add an endpoint, go from the Stripe Dashboard to Stripe > Account Settings Webhooks

    I tested the Stripe gateway on your site and found the following errors in JS Console:

    It looks like Stripe.js is not being loaded from Stripe does not support serving Stripe.js from your own domain.

    Would you please deactivate all other plugins and try to purchase a product again? If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:

    If the issue is still there after deactivating the plugins, please enable WordPress debugging mode, insert this cide in the wp-config.php file:

    define( 'WP_DEBUG', true );

    Please test again to purchase a product. Post here any errors you will see.

    Let us know how it went!



  • Kiley
    • Flash Drive


    Thank you for taking a look at this for me. I corrected my install of WordPress and moved nameservers back to my host. I was thinking that CloudFlare may be the issue. I purchased an SSL from my provider and have it active on the site. Everything is good there. I have only three plugins active on my site all others have been removed. I have the WPMU Dashboard active for support for you and also MarketPress and then a SSL helper. I have checked this test with and without the SSL helper and I am still getting no where. No as far as the stripe js being loaded from my site I am not sure how to correct this. I have not done anything to tell ( to run on my site. I have endpoints set to a thank you page on my site – no where is there documentation showing where the endpoints are supposed to go – also reading a few other posts here on WPMU they all say you don’t need webhooks or endpoints to use MarketPress Stipe payment processing. I am at a loss here. Below is what is in the debug file – the only thing in there.

    [24-Feb-2016 16:26:58 UTC] PHP Notice: Trying to get property of non-object in /home/machin34/public_html/wp-content/plugins/marketpress/includes/common/class-mp-product.php on line 951

  • Kiley
    • Flash Drive

    Okay – after 24 hours I have pulled my debug log and it is nothing but the same error code. I was going to send this in an html file since there was so much of it but it looks like the attachment doesn’t accept – how would you like me to send the debug?

  • Sajid
    • DEV MAN’s Sidekick

    Hi @khernandez,

    Hope you are doing good today :slight_smile:

    I tried to purchase a product on your website using stripe but on submit order I got 500 Internal server error instead of stripe.js issue.

    Did you checked for plugin or theme conflict ? If no then please make a plugin and theme conflict test as described in getting support manual. This basic step is necessary to make sure the issue is with MarketPress plugin or there is other plugin/theme conflicting the plugin.

    I tried to reproduce this issue on my own website but instead of getting internal server error or instead the stripe.js not loading error, I got undefined errors message in stripe_token.js. It seems somewhat related.

    I would ask my colleague Nastia to conduct a test on his site and see what she gets.

    Meanwhile, I am sorry but you can’t attach any files with your reply for security reasons. Please host that file on your website and send in the link of that file (can be dropbox or google drive) link via our private contact form in following format. If you could include FTP and WordPress admin details so we could see the error logs our self or just send in the file link as stated earlier.

    Subject: “Attn: Sajid Javed”

    -Error log file link

    -WordPress admin username

    -WordPress admin password

    -login url

    -FTP credentials (host/username/password)

    -link back to this thread for reference

    -any other relevant urls

    Select “I have a different question” for your topic – this and the subject line ensure that it gets assigned to me

    Take care and have a nice day :slight_smile:

    Cheers, Sajid

    Take care and have a nice weekend :slight_smile:

    Cheers, Sajid

  • Nastia
    • Support Rock Star

    Hello @kiley!

    I’ve read that you added end point to the thank you page,would you please add a correct webhook endpoint url in the Stripe Gateway settings and test again

    Replace with your real domain name.

    Also could you check in your webhooks > logs and see if there any errors?

    Please advise,



Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.