Marketpress error - Warning: in_array() expects parameter 2

I am getting the following error on my site:
Warning: in_array() expects parameter 2 to be array, null given in /home/mjrphoto/public_html/wp-includes/post-template.php on line 1059

It just started happening - I was originally using Marketpress lite, but upgraded to the full version to see if that resolved the issue - but no luck.

It is not a plugin conflict because I deactivated ALL of the plugins except Marketpress and still get the error.

It IS a theme conflict - I activated the default theme and no error - reactivate the custom theme and the error returns -- I am using Elegant Themes Envisioned.

Anyone have any tips or suggestions on how I can fix this error?

Thank you!!