Marketpress Etsy like marketplace New User creation and user website creation

Hi,
I am trying to create a Marketplace using Marketpress. but I am running into problems and I still couldn't find a solution in the community.
I need to build a Etsy like marketplace but I am stopped at the point in which I am trying to figuring out how a user can automatically create a user and his shop.
I am trying to activate it manually but it looks like is not working. when I go to the new site the website doesn't show the thme that I select and manually activate to work with this new site. I just get a simple list of the site content. How Can I have all this automatic and working properly?
Can you point me to the right documentation thanks.
Luca

  • hpidriver

    In your admin dashboard you have to allow registered users to create new blogs. You need to send users to yoursite.com/wp-signup.php to register a user account and then to also to sign up for their own blog. With Marketpress network activated they will be able to use Marketpress to create products themselves. I recommend creating a site that will be the starting point for all new Marketpress stores, use New Blog Templates to achieve this.

  • anotherluca

    Hi,
    I notice that the wp-sign.php does not work with my current theme. If I switch to the basic twenty eleven I can see the page but not with the theme I am using.
    Do you have any suggestion on how can I integrate the wp-signup page with the theme I am using? or I have to change the theme?

    Also I would like to know if there is any possibility to use Redirect login plugin to send the user once he is logged in to his dashboard of his site. What I mean but this is that I want my users to use the main site to login and than I want them to be sent to their web site back-end. Is it that possible? and it is possible to do it automatically setting a dynamic link that check the user name and send him directly to his site dashboard?

    My last question (for now :slight_smile: It is possible to rename the wp-admin with a custom name like for example just admin? How can I do that.
    thanks
    Luca

  • Timothy Bowers

    I notice that the wp-sign.php does not work with my current theme.

    Which theme is that because this is a basic WordPress feature, really they should be supporting that!

    Have you spoken with the theme developer about this?

    Plugins like Gravity Forms and Formidable Pro allow you to create your own signup forms as well as contact forms and such.

    Gravity Forms:

    http://gravityforms.com

    Formidable Pro

    http://formidablepro.com

    Also I would like to know if there is any possibility to use Redirect login plugin to send the user once he is logged in to his dashboard of his site. What I mean but this is that I want my users to use the main site to login and than I want them to be sent to their web site back-end. Is it that possible?

    The plugin Redirect On Login will send them to a fixed if you want to send them to their own admin you need to do something custom here to get theirs sites url and then pass them along.

    My last question (for now :slight_smile: It is possible to rename the wp-admin with a custom name like for example just admin? How can I do that.

    The short answer is no.

    The longer one is sure but with a bumpy road and complications to do so. Is there a reason you need to do this?

    Thanks.

  • anotherluca

    yes if buddypress is disable the link to wp-signup work with every theme. As soon as I activate Buddypress the wp-signup.php stop working and I get sent back to the home page. ?????
    I also notice that with Buddypress Disabled if I try to create a blog form the wp-signup page I can do it but if I go and check the new website/blog the page load but without the theme I have chosen as default one using Blog Template plugin from wpmudev. Also the back-end of those new sites does not work. If I try to go to the dashboard of those new blogs/websites I get a Page not found. ???????
    I am getting frustrated as I am trying to set up a market place with marketpress and so far I can not get to work user website/blog creation.
    What am I doing wrong?
    thanks
    Luca

  • anotherluca

    Have you made sure that you set all the options correctly for New Blog Templates, and that new sites must pick a template?

    I think so I followed the steps in your user guide and make it default.
    Now I also downloaded markeframe and I want to see if this can help with the issue. :slight_frown:

    Is WP Multisite correctly configured?

    I have no idea it is my first MS installation and It looks like it is working. I mean I can create blogs because I can see them in the super admin back-end site network but if I go to the front end user dashboard of the particular site a get a Page Not Found.
    ????? I have no clue at this point.

    Buddypress overrides the default Wordpress registration it seems, but Marketpress should be Buddypress compatible. I

    I am still getting the error when I activate the plugin.

    Is it any way If I give you access to the back-end you can help me with the issue?

    thanks
    Luca

  • Timothy Bowers

    Lots of posts here, just catching up :slight_smile:

    Can you point me to a tutorial or tell me what I have to look for in order to create the custom url to redirect my users?

    I'm not aware of a tutorial but you could look at a function like this:

    http://codex.wordpress.org/Function_Reference/get_active_blog_for_user

    This returns the primary, active blog for a user.

    You would need to feed the current user id as well:

    http://codex.wordpress.org/WPMU_Functions/get_current_user_id

    It really would be rather custom.

    Timothy another thing. Don't you use a dynamic URL to redirect my user to my profile dashboard? and how did you change the wp-admin to https://premium.wpmudev.org/profile/private/

    That's a custom coded profile area and isn't something available right now, sorry. The wp-admin still exists for us:

    https://premium.wpmudev.org/wp-admin/

    You can find your API keys there.

    I noticed that the problem I am having accessing the wp-signup.php page happen when I have Buddypress activated.

    When you use BuddyPress the /wp-signup.php kinda becomes obsolete from the users perspective. You instead get redirected to the BuddyPress registration page.

    You must create these BuddyPress pages:

    Admin --> Network Admin (if applicable) --> Settings --> BuddyPress --> Pages [TAB]

    yes if buddypress is disable the link to wp-signup work with every theme. As soon as I activate Buddypress the wp-signup.php stop working and I get sent back to the home page. ?????

    You need to define the BuddyPress register and activation page page as I just mentioned above.

    If I try to go to the dashboard of those new blogs/websites I get a Page not found. ???????

    This sounds like your wildcard DNS is not working for the domain. Please consult with your host on this one, it will be much quicker than use talking you through it.

    Basically your wild card needs to send all traffic to your WordPress DocumentRoot.

    I have no idea it is my first MS installation and It looks like it is working. I mean I can create blogs because I can see them in the super admin back-end site network but if I go to the front end user dashboard of the particular site a get a Page Not Found.
    ????? I have no clue at this point.

    This relates to your Wildcard setup as I just mentioned above.

    You're host should have this sorted in less than a couple of minutes.

    Let me know how you go.

    Thanks.

  • anotherluca

    hi Timothy,
    I spoke with my hosting and they said that the wildcard DNS is active for my site. because they support worpdress multisite.
    So I am still having the same problem as before.

    I can create blogs because I can see them in the super admin back-end site network but if I go to the front end user dashboard of the particular site a get a Page Not Found.

    Did I tell you that I have the site ad as addondomain to my hosting provider and the wordpress installation is in the main folder I created for this site. could this cause the problem? the people of the hosting said that it would not mater and that I set the addondomain properly.
    :disappointed:

    so what I should do next?

    :disappointed:

  • anotherluca

    timothy, I looked more in into the DNS wildcard and it looks like that I could finally activate it using C panel. now everything works. Thanks for your tip.
    I want just to share a tutorial about the wildcard in case somebody else need help setting it up.

    http://www.webhostinghub.com/support/edu/cpanel/203-manage-domains/how-to-set-up-wildcard-subdomains

    you need that in order to have wordpress multisite to allowed user to create websites.

    thanks again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.