Marketpress eWay plugin problem

I had an old version of marketpress running on vmxmagshop.com.au and I wanted to upgrade to the latest version.
I created a clone site to test - it's at vmxmagshop.com.au/test/
I am using paypal express and eWay
The paypal payments system works fine, but eWay sends an error message when I try to use it to check out.

The message is:

Oops! An error occurred while processing your payment.
There was a problem setting up the transaction with eWay: Invalid Credentials

I have checked with eWay and the credentials I'm using are correct, so it has to be a problem with the plugin.
Other things I've tried:
Just in case there were conflicts with other plugins or customisations, I deactivated all the other plugins but still no luck.
I also tried creating a clean wordpress site with no plugins except for the marketpress plugin, but once again the eWay plugin threw the same error.
Can you help me to resolve this please?

  • Adam Czajczyk

    Hello Margaret,

    I hope you're well today and thank you for your question!

    I believe you have checked the credentials as is API Key and API Password. Would you please double-check too on "Store Settings -> Payments" page if the "Gateway Mode" is currently set to "Sandbox" or "Live" (and if that setting is matching the reality) as MarketPress by default selects sandbox?

    Also, make sure please that all the cache on site and server (if there is any) had been cleared and temporarily disabled, then just simply re-save Payment settings on "Store Settings -> Payments" page.

    That's to start with and if that doesn't change anything, please enable support access to the test site and let me know here.

    You can enable support access by going to the "WPMU DEV -> Support" page in the site's back-end and clicking on "Grant support access" button there. We'll then investigate it further.

    Best regards,
    Adam

  • Margaret

    OK so here's what I've done.
    I've enabled eWay Rapid 3.1 Payments (beta)
    API and password are correct - checked with eWay
    When I check out the eway credit card form appears, all good.
    But then it just goes to a blank page that says username and password required
    The transaction is not recorded in eway.
    What is going on here? All help appreciated. I may have to change to Woocommerce - the eWay Rapid 3.1 Payments works perfectly in that. Only reason I don;t want to change is that there are 98 products in the site from a Marketpress 2.x installation, and checkout with eway shared payments works perfectly in that plugin.
    Would actually prefer to use eway shared payments but that just give an invalid credentials error.
    I'd also like to say that the eway tech people have been really fast at replying to my queries, but I have not had the same experience with wpmudev so far.

  • Predrag Dubajic

    Hi Margaret,

    Apologies for the delay here, it has been a busy weekend :slight_frown:

    I was doing some tests with eWay sandbox on my test account and I had no issues with payments, there were no errors and the payment was recorder instantly.

    Are you seeing this issue only with live credentials or with sandbox as well?

    It seems that support access is not open on your site so I was able to check this further, can you try enabling it again?
    Also, is it ok if we temporary use sandbox eWay details on your site to check if it will work there with those?

    Best regards,
    Predrag

  • Margaret

    I hav opened support access again. Since I had not heard back for 3 days I figured it wasn't safe to leave it open.
    I am getting the same issue with both sandbox and live mode.
    Please go ahead and try whatever you like - it's a test site.
    But i did try the credentials with woocommerce and had no problems. It has to be a marketpress problem. I've been in touch with the eway people today and they have confirmed there is nothing wrong with the credentials for either shared payments or rapid api.
    Thanks in advance.

  • Predrag Dubajic

    Hi Margaret,

    Support access expires on its own after 5 days, and there's no security issue, only our staff can use that and in WPMU DEV > Support panel in your admin you can see who and when used it.

    I did a test with my eWay sandbox credentials and they seem to be working fine on your site as well, here's the email I got after the payment:

    Could you go to WPMU DEV > Support panel and in there you will see message box where you can leave the API details for your eWay sandbox so we could use those and see the issue first hand and try getting more info on this?

    Please reply in the ticket once you have posted them there.

    Best regards,
    Predrag

  • Predrag Dubajic

    Hi Margaret,

    I'm afraid that I don't have eWay live account in order to test this properly so I will need to pass this over to our developers to check it out further.
    Also, as stated in the plugin the eWay Rapid is still in beta so it's possible to have some hiccups.

    Would it be possible to provide us with your FTP or cPanel details so devs can have a closer look at your installation?
    Note: Don't leave your login details in this ticket.
    Instead, you can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: "Attn: Predrag Dubajic"
    - Site login URL
    - WordPress admin username
    - WordPress admin password
    - FTP credentials (host/username/password)
    - cPanel credentials (host/username/password)
    - Folder path to site in question
    - Link back to this thread for reference
    - Any other relevant urls/info

    Best regards,
    Predrag

  • Panos

    Hi Margaret ,

    Apologies for delay here!

    I have done some changes in the eWay Rapid 3.1 Payments (beta) gateway so it should be working now.

    I have attached 2 files to replace:
    marketpress/includes/common/payment-gateways/eway/RapidAPI.php
    and
    marketpress/includes/common/payment-gateways/eway31.php

    Before replacing them I would strongly recommend to first keep a backup of the original files, eg by adding a .txt as file extension.

    After replacing both files you can activate the eWay Rapid 3.1 Payments (beta) gateway and give it a try.

    Hope this helps!

    Kind regards!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.