MarketPress grid view not working (have list view unchecked)

Hi,

I enabled the wpmudev dashboard FYI. The subsite starts with "mechelles." Here is the actual site: http://bit.ly/1maaFak

We have this with "list view" unchecked. It should show as a grid but continues to show as a list under each other.

How can we make it show as a grid and define how many max items or columns across the page the grid should display (the grid should be responsive and adjust down based on screen size etc).

For example, on the homepage we have:
[mp_list_products paginate="1" per_page="10" order_by="date" order="DESC" filters="1"]
[mp_store_navigation]
[mp_related_products]

:slight_smile:

  • Kasia Swiderska

    Hello Greg,

    I've checked this and while unticking "List view" removes the attribute from shortcode it probably doesn't change the defaults. So instead removing it, add it with "0". Like this:

    [mp_list_products paginate="1" list_view="0" per_page="10" order_by="date" order="DESC" filters="1"]

    I've tested on my site and with it, there is grid.

    But for managing columns count, you need to so that in Store Settings -> Presentation -> Product list/Grid settings. Even if you choose List view, you still need to switch to Grid, choose columns, save and switch back to List view.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.