Marketpress & Headway

I'm trying to set up marketpress on a headway built site and am running into what looks to be familiar issues.

The store page shows up fine but I can't seem to view the products page...or individual products. I know there have been posts talking about how the two are fully compatible, is there some sort of trick to getting them to work together?

  • PC
    • WPMU DEV Initiate

    Hiya,

    Greetings and thanks for posting on the forums.

    First of all, did you try and refresh the permalinks ?

    The same kinda issue was also discussed here : https://premium.wpmudev.org/forums/topic/marketpress-products-page-not-showing-products

    I don't have a working copy of the headway theme so I can't install and check it right away so I will have to ask a few more questions as we go along.

    Also, please ensure that you are running the latest versions of WordPress and MarketPress

    Cheers, PC

  • jeremy_moncur
    • Flash Drive

    Pranaya,

    Thanks for your response. I'm running Wordpress 3.5.1 and marketpress 2.8.1.

    I'm using the postname settings on permalinks and have refreshed multiple times.

    I took a look at the thread you referred me to and followed all instructions. However, this "Products" page won't fall under the store menu and becomes another menu item in order to be reached (view site at http://www.theartofcarlosmozo.com). Also, once you view the products page and add a product to the cart, you can't see your shopping cart page cause it has the same problem the original "Products" page had. It doesn't show up. Just defaults to the home page layout.

    Not sure what to do, if it helps I'll get you a copy of the latest Headway Theme so this can be figured out as the two (Headway and Marketpress) are definitely not 100% compatible at the moment.

    Thanks

  • jeremy_moncur
    • Flash Drive

    Jim, I'm running all the same versions of Headway, Marketpress and Wordpress. I also installed WP Cache Block and flushed the cache but it's not doing anything.

    If you could get in and take a look around I'd appreciate it. I can create a temp account. What user permission do you need and how could I get it to you?

  • jeremy_moncur
    • Flash Drive

    Jim,

    I just did a fresh install of everything. Wiped my database clean in c panel and all. Then I reinstalled everything and am still having the same problem. Very confused as to why this would all work fine on one site and not at all on another.

    is there any formatting done in headway grid? i don't think there should be as my northshorerealestateclub.com site works great and i haven't touched the headway formatting. just installed the plugin to an already formatted site.

    any special process your using? i make sure the permalinks aren't on default, created a few products and made sure to save in the presentation tab of marketpress options as directed. any ideas???

  • PC
    • WPMU DEV Initiate

    Hello Jeremy,

    Greetings and thanks for your post.

    Apologies for the delay on this one as I had to be away with my family due to a bereavement.

    Can you please send me the login details (Admin account) via our contact form so that I can have a closer look and try to replicate it on my lab site ?

    Please advise.

    Cheers, PC

  • PC
    • WPMU DEV Initiate

    Hello Jeremy,

    I had a look at your site and found that its not showing up any custom post types. I tried creating a sample post and it also showed up white.

    Can you contact headway support and check it with them once. Once the custom post types start showing up, this will be sorted out.

    Please advise.

    Cheers, PC

  • jeremy_moncur
    • Flash Drive

    Pranaya,

    I figured out a workaround to make it all work. Not the out of the box solution I hoped for but pretty close. Instead of creating a custom layout for the default headway layout (blog index) page, I had to select one of their preset layouts which includes a content block where the store, products, etc...show up. Everything but that content block can be changed (can't delete it and create your own content block, have to stick with the default but changing its size and position is ok, as well as any changes in the headway visual editor), but once the content block on the blog index page is changed, none of the marketpress pages will show up.

    Because I don't want their default layout as my front page I have to create another page in wordpress and assign it as my front page in the settings > reading section.

    Having done that all works great. Just wanted to let you know incase others run into the same problem. Thanks for your help!

    Jeremy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.