Marketpress keeps deactivating network-wide

Hi

It is probably just me, but several times in the last 6 months I have found my marketpress plugin deactivated.

I do auto-updates here and there which could be a cause.

Just wondering if anyone else has mysterious deactivating plugins?

Cheers,

Johnny

  • Timothy Bowers
    • Chief Pigeon

    Hey Johnny.

    I've not seen that happen on any of my production or sandbox installs. Odd.

    Any other plugins enabled which alter the state of another? Any fatal errors in your servers error_logs?

    For example normal plugins can be deactivated by Pro Sites. (not network though). Painful but I suppose checking it every time you do something would find the issue.

    Take care.

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • johnnymestizo
    • HummingBird

    I found it deactivated again !

    It seems that marketpress cannot be force activated using the mu-plugins folder.

    Is there anyway to ensure marketpress is activated on all sites forever?

    It is so intermittent that I cannot deactivate plugins until it happens again.

    Any work arounds ?

    Thanks,

    Johnny

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    Thank you for the additional input and for letting us know about this phenomenon which has never happened to me EXCEPT when doing an update of the plugin through the dashboard on a server with gzip compression running.

    Then once it is finished updating I must reactivate the plugin manually.

    Please advise and make note if this is indeed when this is happening.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    Thank you for your additional input, it is appreciated.

    I only found this phenomenon when a certain plugin itself is updated, for example you would have had to do a Market Press update for the phenomenon to occur that I am referring to.

    I have no idea if you can force it to be on otherwise then network activating it.

    Therefore I will see if I can get the lead developer in here with his invaluable insight into this plugin for his advice/advise for us.

    Though this may take a bit longer then a normal ticket, I will try to get him in here asap.

    Cheers, Joe

  • johnnymestizo
    • HummingBird

    A point to note:

    Because of this issue, I have activated it on network sites manually in the past.

    Even though, it is network deactivated somehow - the network sites have individual site plugin activated.

    Is there any forceful activation possible?

    Can this please be marked as urgent as it is crucial to my site.

    Many thanks in advance,

    Johnny

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    Thank you for the additional input, it is certainly appreciated.

    I will certainly be seeking to get the lead developer in here to offer his advice/advise as to what the issue possibly may be.

    The message to the lead developer is sent and we shall wait for his arrival, there is nothing more I can do regarding getting him in here then I have just now.

    However, though not relative to getting the lead developer in here, if Market press is indeed site activated, when it is no longer network activated as you have indicated is happening, what negative effects are happening due to this network activation being off? I would think if site activated there are no negative consequences, but of course I do not know everything but that is why I ask?

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Johnny,

    Thank you for the additional input.

    I have Market press network activated and I have never had an issue with deactivation.

    Perhaps that is what is going on there, you perhaps should have it network activated?

    Please advise.

    Cheers, Joe

  • Aaron
    • CTO

    The only time I have ever seen this is when autoupdating, as sometimes there is an error or timeout before WP can reactivate the plugin.

    There is nothing in MarketPress itself that would make it any more prone to being deactivated. It sounds like a server issue to me, maybe the network activated site option being changed by something, or getting corrupted. Does this happen with any other network activated plugins? Was it you that had similar issues with site options (pro sites settings I think) not being kept? Do you have a persistent object cache, like memcached installed?

    Note MP is designed to work from mu-plugins, you'll just need to take it out of it's containing folder. And test well as I havn't tried it that way for a long time.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.