Marketpress Multisite Dashboard

So I have the marketpress plugin installed and modified it to a multisite - it works fine. But now all users have subscriber access levels, yet it looks like admin level. How do I modify the access?

  • aecnu

    Greetings brazuka,

    Welcome to WPMU Dev!

    The control of access to Market Press plugin and its features can be done using a few techniques in which I shall cover briefly:

    Without any other plugins to control Market Press you have limited control to the point of network activated or manual site by site activation - but you can not control end users from activating it either.

    With the edition of Pro Sites plugin it offers a great deal more control of almost all the plugins in your network installation controlling plugins by levels that have been defined by you.

    There are other ways to control access to plugin features to include but not limited to the Membership plugin and Multisite Plugin Manager

    As you can see from my examples above control of Market Press plugin as well as others ranges from the simple to the very complex integration of membership plugin and more.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • aecnu

    Greetings brazuka,

    Currently, I am not able to see the plugin and I no longer have access to edit plugins in the admin bar?

    Try removing the Multisite Manager plugin via FTP and do a re-upload. Something must have gone wrong in the transfer.

    I just now tested it and it comes up fine in the network admin --> Plugins --> Plugin Management

    Also once I figure this out, how would I go about giving access to user to create there own store...is there docs or links on this set up somewhere?

    Pro Sites plugin is the one to use for this task and well suited to manage plugins too - with Pro Sites plugin you will probably not want Multisite Manager plugin because it has similar plugin control and much more.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

    If this thread is not resolved because the suggested action did not work or you have any more questions related to this thread, please feel free to post them below including any new symptoms or errors and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)