MarketPress not adding products to cart when Hummingbird Minification enabled

Is not possible to add products to cart on MarketPress when minification is enabled.

The issue is presented in carrollssausage.com

Access details provided to staff.

  • Jorge Díaz

    Hey there Joshua, Jorge here following up.

    I've escalated this issue, in the meantime, could you please try adding the following to the functions.php of your child theme:

    add_action( 'init', function(){
    
        if( ! function_exists( 'mp_is_shop_page' ) || ! mp_is_shop_page() ){
            return;
        }
    
        add_filter( 'wp_hummingbird_is_active_module_minify', '__return_false', 500 );
    
    }, 10 );

    Just let us know if you add it so once we check the issue on your site we can disable it to run some test.

    Looking forward to your reply.

    Have a great day!

  • Rupok

    Hi Joshua,

    I'm so sorry to hear the inconvenience and I do apologize for the delay. We will try to make sure that this type of delay doesn't happen again.

    I'm confirming you that our SLS (Second Level Support) Team is currently working on this.

    As the workaround Jorge mentioned above didn't work for you, can you please login to your server with any FTP application like FileZilla and replace existing
    "wp-content/plugins/marketpress/ui/js/frontend.js"
    file with the attached frontend.js file (I've attached a zip file. Please download and extract that, you will get that frontend.js file)? Please make sure you re-minimize in Hummingbird after replacing the file. And I'll also suggest you take a backup of your previous frontend.js file before replacing.

    Please let us know how it goes. If this doesn't resolve the issue for you, we will be glad to investigate further.

    I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Joshua

    Did that and then could not log in to the website admin to rerun the minification. Undid the code in the functions.php, still could not get in. Undid the frontend.js and still can't get in. All combinations get me the following (front-end still seems to be working, but nothing on the other side of wp-admin works):

    "unused

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, *** and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log."