Marketpress not working

Howdy,

I have been using Marketpress for a couple years. Currently, when I click on "Add to Cart," nothing happens. The wheel just spins. This is happening on the primary and subsites.

I deactivated the plugin and then re-activated, but that didn't help.

Can you please take a look. I have granted access.

Must use http://wordsandwriters.com, not https://wordsandwriters. I am having a problem from Chrome browser which is defaulting to https:// and kicking error messages. That's a different issue.

Thanks, Joe.

    Nastia

    Hello joejacobson , I hope you are doing well!

    Please let me know, have you installed or updated any plugin before this issue occurred? I tested the MarketPress plugin on my site and can't replicate the same, it is adding a product item successfully.

    Have you checked if there is a conflict with another plugin that is activated on your site? There are several JS errors in the browser console which indicate a conflict with another plugin.

    To check for a conflict, switch to a default WordPress theme, leave the MarketPress activated and deactivate all the other plugins. After this, try to add a product to a cart.

    If everything is well, activate one plugin at a time to find the one that causes this.

    Follow the steps from the flowchart:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Let me know how it went!

    Kind regards,
    Nastia

    joejacobson

    Hi Nastia,

    I did the plugin and theme test, and it turned out to be Hummingbird. I left it deactivated for now.

    Now what? Need to report it to the developer? Below is an error message after re-activating Defender plugin (Jetpack seems to be okay):

    arameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 92

    Warning: stripos() expects parameter 1 to be string, array given in /home/josen/public_html/wp-content/plugins/jetpack/modules/shortcodes/class.filter-embedded-html-objects.php on line 98

    Sajid

    Hello joejacobson

    Thanks for making the conflict test and letting us know what is the conflicting plugin.

    I tried to replicate this issue on my own site and could replicate a similar issue with Hummingbird plugin's minification and MarketPress add to cart spinning wheel.

    It was due to a jQuery conflict that I resolved by repositioning the mp-cart.js and frontend.js files into footer (see screenshot).

    Please do that and let me know if that fixes this issue.

    Also, I could not login to your site. Please disable/revoke support staff access and then try again, so I could take a closer look.

    Take care and have a nice day

    Best Regards,
    Sajid - WPMU DEV Support

    joejacobson

    Hi Sajid,

    I looked in my Hummingbird settings and did not see the minification link as you show.

    I have granted access again, so I hope it's accessible again.

    Please take a look and let me know. BTW, I did the recommended steps by Nastia and that didn't help.

    I have deactivated the Hummingbird plugin for now so my Marketpress is working. If you figure it out, please be sure Marketpress is working. I have it installed in the primary domain.

    Thanks, Joe.

    Nastia

    Hello there joejacobson ,

    Thank you for granting access to your site. The Hummingbird plugin was deactivated, so I activated it to move the JS files to a footer. After some testing, I've deactivated minification for mp-cart and mp-coupons JS files because there were some JS errors on the Checkout page.

    This has fixed the issue with "Add to cart" button and it is working from my end. Would you please confirm that it is working well from your end?

    Please advise,

    Cheers,
    Nastia

    Nastia

    Hello there joejacobson ,

    The Add to Cart button is working from my end. Though the Checkout page give the "ERR_TOO_MANY_REDIRECTS" error. This issue happens event with the minification deactivated.

    It looks like the issue happens because it forcing SSL on the checkout page. I've deactivated Force SSL option from Store Settings > Payments > Stripe Settings and it solved the issue.

    Please let me know, do you have SSL certificate installed? If yes, there are other ways to force HTTPS.

    In case you don't have SSL installed, you can create one for free with Let’s Encrypt and then use a plugin WP Force SSL or similar to force HTTPS on your main site.

    Please note, all subdomain multisites requires Wildcard SSL certificates to force SSL on an entire network. If you wish to force SSL on each of the subsites, you will need to create SSL certificate with Let’s Encrypt for each subsite separately, since it's only provides Single SSL certificate.

    Let me know if you have any further questions!

    Kind regards,
    Nastia

    joejacobson

    Hi Nastia,

    I do have an SSL certificate installed and I eventually want to have all subdomains with their SSL because of Google Chrome's requirement of a "secure" site. My hosting charges for additional subdomains using the wildcard SSL, so I welcome your free option. I will look into this soon.

    However, my priority now is that I still am not able to add a product. I have cleared my Super Cache and browser cache. See the attached image of the error message.

    By the way, I am running Prosites (which is also not functioning properly at this time), and I believe I needed the SSL for that plugin...I think. Maybe I'm wrong. I have a separate ticket in for the Prosites issues.

    Thanks, Joe.

    Nastia

    Hello joejacobson ,

    We talked about it in last chat session. Please send to us your credentials, so we can have a closer look.
    You can send credentials by using our secure contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question

    Subject: “Attn: Nastia”
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Link back to this thread for reference
    - Any other relevant URLs

    *No need to send WordPress credentials since you have support access granted.

    I am waiting for your email!

    Kind regards,
    Nastia

    joejacobson

    Hi Nastia,

    Access now granted. By the way, I installed a plugin called Really Simple SSL which seemed to solve the problems I was having with my Registration page (Prosites) not functioning properly and other SSL issues.

    Just wanted to let you know in case that affects your troubleshooting. Please leave that plugin in place.

    Also, I have Marketplace active on this subsite: joannlordahl.com, which is also not working.

    Thanks, Joe.

    Nastia

    Hello joejacobson ,

    Thank you for your patience!

    The issue was that the MarketPress plugin's scripts were minified and some JS files needed to be loaded from original positions and others from the footer.

    Just in case you will need to edit modification again, please keep this screenshot of Marketpress files minification settings, so you can set them back to their place:

    At this time the cart is working from my end. Would you please have a look and make sure that is working from your end?

    Kind regards,
    Nastia

    Nastia

    Hello there joe,

    Does this fix need to be done for each subsite?

    Yes, this fix needs to be done on subsites too. At this time based on the settings on your site, only super admin can have access to Minification. If needed, you can change these settings in the network admin, go to Hummingbird > Dashboard, check under Minification section:

    The Minification feature located on each site's dashboard under Hummingbird menu. Please see the screenshot:

    If you need my assistance, I can set the minification on subsites as well, just please let me know on what subsites the MarketPress plugin is activated.

    Please advise,

    Kind regards,
    Nastia

    Nastia

    Hello joejacobson

    I can replicate the same issue on my end when it comes to mp-base CSS file in
    wp-content/plugins/marketpress/ui/css/marketpress.css

    The @import rule is used to import style rules from other style sheets. So when it comes to minification it might cause some issues.

    I've reported this to us developers so they can have a closer look. The Hummingbird will not minify this file till the @import rule is changed, so it shouldn't cause any issues on your site.

    As for the second file mailchimpSF_main_css Hummingbird can't recognize the file's type beacause of it's extension:
    ?mcsf_action=main_css&ver=1.5.7

    It looks like the MailChimp plugin is loading styles from this file. I am not very familiar with this plugin and renaming the extension of this file might break the plugin's stylesheet.

    At this time, Hummingbird if can't process the file it will ignore it, so this will not affect the plugin's function in any way.

    Hope this helps!

    Cheers,
    Nastia