MarketPress orders notifications to admin not working

MarketPress is not sending any notification of any order to the admin, it only sends it to the customer.

I’m using Authorize.net on my site and after enabling the sandbox on it I got this message (but still no admin notification email):
“Oops! An error occurred while processing your payment.
There was a problem finalizing your purchase. The merchant login ID or password is invalid or the account is inactive. Please go back and try again”.

  • Predrag Dubajic

    Hi Robert,

    Hope you're doing well.

    Can you try going to Store Settings > Notifications panel and for admin notification settings under "Notification Email" field use the same email as the one set under Settings > General panel and see if the email is being sent to that address?

    I’m using Authorize.net on my site and after enabling the sandbox on it I got this message (but still no admin notification email):

    Seems like we had similar report about this previously and that it was related to server setup as mentioned here:
    https://premium.wpmudev.org/forums/topic/authorizenet-transaction-missing-details#post-1039997
    Can you check this with your host?

    Best regards,
    Predrag

  • Robert

    Good morning. Hope you are doing well.

    All credit card transactions are working correctly and being processed through my bank's credit card system.

    Still no admin email after changing the MarketPress notification to the one in WordPress general settings (webmaster@okobserver.net). No notification is received on either manual payment (check, money order) or credit card.

    I see in the ticket reference to "So.... it turns out there was a glitch related to the Session Path on the server side."

    I contacted our web hosting provider, iPage. They indicated the following:
    ---
    "One of our VPS specialists checked and your session save path is set to: /tmp/ for that one which is valid.
    But we are unable find any "glitch in the session path"
    ---
    Any other ideas?

    Thanks again.

  • Predrag Dubajic

    Hi Robert,

    So is the notification about failed payment gone now and they are working properly?

    About the email issue, it's strange that it sends to customers but not to the admin itself as the functionality is pretty much the same, I just wanted to check if it can be related to difference between admin email and customer.

    Have you tried purchasing an item with your admin email, does the client email get sent to that email?

    Also, could you try configuring SMTP on your site with a plugin like this one https://wordpress.org/plugins/easy-wp-smtp/ so we can see if the issue is related to WP native email sending functionality?

    Best regards,
    Predrag