MarketPress Orders Page showing first only

Hi,

On Market Press orders page, showing only FIRST order of each page. Also breaking 'screen options' so probably a javascript issue.

Happends on production and also on my test site (as per this ticket)

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Locally,

    Hope you are doing good today :slight_smile:

    It appears to be a plugin or theme conflict. Please run a quick plugin and theme conflict test as illustrated in getting support manual (flowchart).
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If still getting the issue, then please grant support staff access so I can take a closer look. To grant support staff access go to WPMUDEV > Support > Support Access > Grant Access or see this manual.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Locally,

    Hope you are doing good today :slight_smile:

    Yes, I can see it now, there is something after shipping that is terminating the execution. Can you please enable debugging so I can see the error ?

    Let me know when you enabled it so I can take a look.

    Hope that helps! If you still need assistance, don't hesitate to ask.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Locally,

    Hope you are doing good today :slight_smile:

    Thanks for enabling the debugging mode. I can see the issue now, this helped a lot. Just before taking the necessary actions. Can you please tell me that you have updated from MP 2.9.6.2 ?

    Also, when exactly this started happening, I mean after you updated the WP to 4.4 ?

    Hope that helps! If you still need assistance, don't hesitate to ask.

    Take care and have a nice day :slight_smile:

    Kind Regards,
    Sajid J

  • Sajid
    • DEV MAN’s Sidekick

    Hi @Locally,

    Hope you are doing good today :slight_smile:

    Thanks for providing useful information. I could replicate the same issue on my own site. Therefore I am marking it as confirmed bug and notifying the developer so it can be fixed in next release.

    Please keep an eye on this thread for updates and I am glad you have a workaround for now.

    Take care and have a nice weekend :slight_smile:

    Kind Regards,
    Sajid J

  • Jose
    • Bruno Diaz

    Hello @Locally,

    Hope you are doing great.

    There is an issue with orders created in MP versions previous to 3.0.

    A fix will be released soon. In the meantime, you can solve this by changing the line 1076 in
    wp-content/plugins/marketpress/includes/admin/class-mp-orders-admin.php
    from this:
    $cart = $order->get_meta( 'mp_cart_info' );
    to this:
    $cart = $order->get_cart();

    Please let us know if you need help implementing this change.

    Cheers,
    José

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.