Marketpress PHP 7.1 updates required

Please resolve:

[27-Sep-2017 08:01:17 UTC] PHP Warning: array_keys() expects parameter 1 to be array, null given in /home/cheryblk/public_html/wp-content/plugins/wordpress-ecommerce/includes/common/class-mp-cart.php on line 445
[27-Sep-2017 08:01:17 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/cheryblk/public_html/wp-content/plugins/wordpress-ecommerce/includes/common/class-mp-cart.php on line 439

access to Support on cherryblack.com.au has been provided.

  • Panos
    • SLS

    Hi @##Garth ,

    Thanks for reporting this!

    This should not be causing any issues on your site as it is just a warning when the cart is empty and some functions that expect some input have empty input.

    This should be fixed in following release, until then you can replace file :
    wp-content/plugins/marketpress/includes/common/class-mp-cart.php
    with the one attached here.

    I would strongly recommend to keep a backup of the original file, eg by renaming it to class-mp-cart.php.txt and then uplaod the one attached.

    Please let us know if you still see these warning after replacing it.

    Cheers!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.