Marketpress Plugin Throwing Table Database Error

I have installed the Marketpress plugin on an existing multi-site.
A year or so ago I had Marketpress installed but it was deactivated. Because of these errors I further purged it by removing the file structure from the plugins folder.

I also reviewed the database and looked for any instances of mp_ and removed it.

After activating the plugin on my development server I get this error:

WordPress database error: [Table 'cm_word4ya.cm_mp_terms' doesn't exist] SELECT * FROM cm_mp_terms WHERE type='product_category'

So I repeated this procedure on my staging server and things went normally. No error.

So then I copied the entire database and file structure from the staging server to the development server and I still get this database error above. I simply cannot activate the plugin without the error which renders the site unusable.

I HAVE disabled all other plugins to see if it solved this problem... it does not. So it's not a different plugin as Marketpress was the only plugin in the folder.

Your thoughts ?

Jay
CompuMatter