Marketpress presentation product page setting custom size not working

Site specs: PHP 7.0 / WP 4.7.2 / custom Gavick Quark theme / MarketPress set to default css
Support access provided.

Under the Settings > Presentation menu
Show Product Image: Yes
Images size: Custom
custom size: 500 x 500

eg. Product page http://cherryblack.com.au/wp/store/products/the-lost-mayan-blend/

however blank placeholder displays and inspect shows that it is loading http://cherryblack.com.au/wp/wp-content/uploads/cbr_250g_w-1x1.jpg

Additional note: Marketpress ajax cart js doesn't work under PHP 7.1

  • Rupok

    Hi Garth Penglase,

    Thanks for asking. I tried to regenerate this on my test site but I could not. My product image is showing proper 500x500 px image in product page and the image frame is also not blank. Please check the attached screenshot for reference.

    But I went to your site and I could regenerate this issue on your site. So I think, this is your site specific issue.

    Just to make sure no other plugin is causing this, can you please do a plugin conflict test? To know more about plugin conflict test, you can check this guide: http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    And also to make sure that your current theme is not responsible for this in any way, can you please try activating any default WordPress theme and check if the issue is still there?

    Please let us know all these details. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Marketpress ajax cart js doesn't work under PHP 7.1

    I also tried to regenerate this with PHP 7.1 and I could regenerate this on our test site. So I'm reporting this to our developer right now as a confirmed bug. I believe, he will come up with a fix very soon.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and release a fix. I appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • #Garth

    I have disabled all plugins but marketpress and WPMU DEV Dashboard
    I have download Twenty Seventeen and activated that as the theme. It still is not working.

    I set DEBUG on (display and log) in wpconfig, and set a new php_error.log file to 660
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    @ini_set( 'log_errors', 'On' );
    @ini_set( 'display_errors', 'Off' );
    @ini_set( 'error_log', '/home/cheryblk/wp/logs/php_error.log' );

    (the crazy thing is that even with this set in wpconfig, it didn't show any debug results nor is it now logging any errors - I even created a phpini file with the same settings. I can't figure that one out.

    So I set both php.ini and wpconfig to DEBUG On DISPLAY Off (still not working).

    HISTORY
    This started out as a Woocommerce shop. We installed Marketpress because we wanted to test Marketpress out. Utlised the existing posts, and products. Manually setup Marketpress, setup the 5 product prices, variations. I have replaced the same images several times, deleting the existing images, setting new settings in Marketpress > Presentation and then loading the images into Media Manager, trying to work out the best combination of images for the standard setup of Marketpress.

    THINGS I NOTED WHEN DIAGNOSING THIS:
    If I install new images with a custom setup, it will display the blank-coloured placeholder, even though, as is expected, the system has created 500x500 images from the source image.

    Not surprisingly, the only images for which Marketpress has created -1x1.jpg versions of are the images which are selected to be used on the Products page. I also notice that the 500x500 images now have a time on them as of only 1:16 and yet I have not uploaded new images, so they seems to be created whenever the Custom Settings are updated and the individual product page is reloaded.

    If I change settings to a non-custom setting (say 320x320 or 240x240) it will display the selected image (ie. ending in -320x320.jpg or -240x240.jpg) but *scaled up* to 500x500 pixels instead (ie. the custom size I specified prior to changing it from custom).

    One more thing is that the I tried this initially uploading images that were 700x700 and this still happened. I then tried 500x500 because I wanted the original images to be referenced as the large image. 2 things to note:
    a) when the image is clicked to view the pop-up large/original image it does display the original image ie. http://cherryblack.com.au/wp/wp-content/uploads/cbr_250g_w.jpg
    b) the script doesn't use the original image even though it is the specified custom size. This may be understandable given the way the system generates the product page image on the fly if it isn't already created it adds the required suffix (ie. 1024x760.jpg) but it results in properly compressed JPGs being made larger than the original file (not by much by still is affecting the image size by 15% or so)

    Also, when I selected the large setting of 1024x760 it created that image on the fly as well, from the lower res base image. But it then displays the resulting image ie. http://cherryblack.com.au/wp/wp-content/uploads/cbr_250g_w-1024x760.jpg BUT very interestingly it is ONLY 500x500 pixels in dimension.

    Well, I certainly found a way around this problem for myself, even if it is still buggy :slight_smile:.

    However, something is definitely wrong here. It shouldn't be creating 1x1.jpg images when a custom size is selected.

  • Nithin

    Hi Garth Penglase,

    Hope you are doing good today. :slight_smile:

    Sorry for the delay, Is this a live site? Is it okay, if I could give a closer look, by disabling the plugins, and switching the themes to have a better idea about why it's causing this issue? I don't want to make any such changes, if it's live, or whether you are working on it. Please do let us know so that we could help get this resolved asap. Have a nice day. :slight_smile:

    Kind Regards,
    Nithin

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.