MarketPress Problem, Can't finish checking out

Anybody here successful at getting marketpress working with HTTPS plugin for SSL? My site e-t-h-er-do-se.com (without the dashes) can add items, but when you try to check out with a "manual payment" it stalls before confirmation, as well as the credit card SWIPE gateway check out. Any help?

  • edlikestoboogie
    • WPMU DEV Initiate

    Hi aaron,

    It did NOT work when my website was just plain wordpress + marketpress barebones, same problem, a user would try to checkout, and whether you use manual payment or SWIPE, the "confirm payment" page is shown, and then nothing, no content past that header.

    and to MasonJames,

    Hi,

    I don't know if it is a problem with manual payments and swipe, I tried disabling one or the other, and still it just gets stuck on "confirm payment". I don't understand how marketpress + wordpress could fail right out of the box like this, it is frustrating.

  • Mason
    • DEV MAN’s Sidekick

    Hiya,

    I'm only encountering an issue with both Stripe and manual payments activated. When I have either one activated individually all is fine.

    Did you try what Aaron said about not using the https plugin? It isn't needed in this case. Can you verify that the correct information is entered in the Stripe gateway settings?

    I'm getting this message when attempting to checkout via Stripe:

    Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.

    Are you sure you want to continue sending this information?

    That's not something I would normally see, which leads me to believe something is setup incorrectly either with SSL or the Stripe gateway.

    Thanks!

  • PC
    • WPMU DEV Initiate

    Heya Fella !

    We are still waiting for a response from you on this :-

    Did you try what Aaron said about not using the https plugin? It isn't needed in this case. Can you verify that the correct information is entered in the Stripe gateway settings?

    Did you happen to try that ?

    Please advise

    Cheers
    PC

  • aecnu
    • WP Unicorn

    Greetings edlikestoboogie,

    We have not heard back from you as to the status of this issue.

    If you are still having an issue please let us know so that we may try to get you fixed up as soon as possible by choosing to check mark this ticket as unresolved below and posting any new errors or symptoms you are noticing.

    This action will also bring your ticket up front back in plain view again within the ticket system.

    Thank you for being a WPMU Dev member!

    Cheers, Joe

  • netherworks
    • WPMU DEV Initiate

    I believe that this issue is related to the issue I'm having as well. When you have the Stripe Payment method selected as an option, along with other Payment options, the Stripe CC form isn't passing form field validation even though it's hidden. This is a bug that the developer will have to work out. Some possible solutions would be to:

    1.) Wrap each payment method in it's own form
    2.) Disable the Stripe form validation when the Stripe option (radio button) isn't selected.
    3.) Render the payment method forms only when the option is selected (through ajax maybe)

    Anyway, hope this helps.

  • Timothy Bowers
    • Chief Pigeon

    The issue in this thread relates to the server not having CURL installed. Our Gateway could not connect to Stripe to process payment.

    HTTPS on this install was forced in htaccess with all references in the db also using https. There was also a HTTPS plugin which wasn't activated.

    I was able to connect and process from my own sandbox install.

    I see on your other post that Aaron was flagged there, Paul is covering his plugins for another week or so and as such has a huge load so I'll ping him again to see if he can assess.

    Thanks.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.