MarketPress product price disappearing

When going in to edit a product, under some conditions the price of a product disappears. My client reported this a few days ago and I have been unable to figure it out. I set up a product called "Test Product" to test this and have it set to "pending" so that it doesn't show in their store. A typical way to reproduce the problem is to preview the product, then make a small edit to the description and save the product. Typically, that will result in the price going away. If it doesn't, doing the edit and save another time or two will trigger it.

I am turning on support access now.

  • Predrag Dubajic
    • Support

    Hi @richard_norby3,

    Hope you're doing well :slight_smile:

    I have checked your installation and could see the issue after the first try, however when I try the same thing on my installation I can't replicate it even with about 10 saves and edits.

    Have you tried disabling your other plugins and switching to default WP theme so we can see if there is some conflict on that end?

    Best regards,
    Predrag

  • richard_norby3
    • Site Builder, Child of Zeus

    Thanks Predrag,

    I have noticed the same thing, that the error doesn't occur in my test installations, even if I have the site duplicated exactly. I have been hesitant to try turning off the plugins because it is a live site, however, tonight I will take the site down for maintenance and try it.

    I have a hunch that this is related to session variables and IP address, but so far have not been able to uncover anything there.

    Thanks again!
    Richard

  • jetmac
    • Recruit

    I have the same problem.

    Just updated and products won't hold their pricing -- disappears on update.

    This is not an issue on my Dev site, which is identical to the live one.

    Also, any site that doesn't have any products will not complete the database update (hangs at 0%).

    I have no choice, I have to revert back to the previous version. Let me know when you figure out why this is happening.

  • Predrag Dubajic
    • Support

    Hey guys,

    Can you tell me which host are you using and what's the PHP version on your sites?

    @jetmac I was able to replicate the issue with sites without products hanging on database update, I will report this bug to developers and in the meantime you can use this to force update and that should work:
    domain.com/wp-admin/admin.php?page=mp-db-update&force_upgrade=1

    Best regards,
    Predrag

  • richard_norby3
    • Site Builder, Child of Zeus

    Hi Predrag,

    I'm using WP Engine as my host. I just ran a test where I disabled every plugin except MarketPress and still got the same problem. When I clone the site to the WP Engine staging site, it works fine.

    Here is PHP and Server info PHP Version 5.5.9-1ubuntu4.14.

    I have extended support access in case you want to look more at the backend. Just keep in mind it's a live client site. If you do login, I have a PHP info plugin installed. If you go to "Settings" and select "WordPress phpinfo()" you can see the PHP info. Also, in my security plugin, "WP Security" in the admin menu, will let you look at the current htaccess and wp-config files (in the "settings" tab).

    Hopefully we can get this resolved soon. My client is being patient for now, but will soon start to get upset.

    Thanks!
    Richard

  • Predrag Dubajic
    • Support

    Hi Richard,

    Thanks for the info, I've managed to get a hold of WP Engine account for testing purposes and it looks like it's related to Object/Transient Cache.

    You might want to disable caching while in development, as the WP Engine suggest in that option info, quote:

    Generally you want this enabled for maximum speed and scale, but if your site is under active development or if you have a theme or plugin which is incompatible it might be more convenient to have it temporarily disabled.

    I will however forward this to plugin developer to see if there is anything from our end that could be improved to work with object caching enabled.

    @jetmac is your site hosted on WP Engine as well?

    Best regards,
    Predrag

  • richard_norby3
    • Site Builder, Child of Zeus

    Hi Pedrag,
    Turning off the Object/Transient Cache seems to have done the trick. It would be great if the developer could find another solution since the client adds and updates products on a regular basis. I'm leaving this ticket open for now since jetmac is still having a problem.
    Thanks!
    Richard

  • jetmac
    • Recruit

    Pagely also has an aggressive cache, so perhaps there is a relationship in our problems, Richard. But, again, I have the same issue with clients adding their own products regularly -- and, I don't allow them access to advanced functions like control of the cache.

    This doesn't happen in the pre-MarketPress 3.0 version.

  • Adam Czajczyk
    • Support Gorilla

    Hello guys!

    It seems that both this cases are indeed closely related. I'm not sure about Pagely cache @Jetmac but isn't there any option to switch it off for entire server/hosting account just to confirm that this is the issue?

    @richard_norby3,
    Thanks for confirmation! Since my colleague @Predrag Dubajic has already forwarded it to the developers, I hope they'll be able to figure it out and come up with a solution!

    Best regards,
    Adam

  • Adam Czajczyk
    • Support Gorilla

    Hello @richard_norby3,

    I hope you're well today!

    I understand that you've upgraded to the latest MarketPress release? Have you already checked if the store is working again with cache switched on? I think the fix should have already been release with update. Let me know please if it works for you and if not, I'll keep nagging developers to give it another look urgently!

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.