MarketPress sending item shipped email as soon as an item os ordered with list of every item

We really need help with this. Client is really mad.

MarketPress is sending order shipped email as soon as an order is placed. The email is not correct and list every item in the store. We are running MarketPress in a sub-directory multisite with domain mapping. The site we are noticing this on is shopfah.com (Which is our first client on this network, so we can say if this issue is happening any where else). The sites payment gateway is in test mode. So, please try this. When we actually set the item to shipped the correct email is sent.

I have added the emails that are being sent.

  • Kasia Swiderska

    Hello Bryant,

    How can I replicate this issue on your site? I created now a order there and payed and this is email I've got:

    I did ot receive any more email notifications form that store.
    In order to replicate issue would you mind allowing support access so we can have a closer look at this?
    To enable support access you can follow this guide here:
    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    kind regards,
    Kasia

  • Bryant

    Thanks,

    What I have come to is could we be receiving this because the user and we where logged in during the test purchase? The emails I attached we did that test while logged in and I am assuming3 the user was logged in as well. Because they are the admin my thinking is that they would be the Administrator and owner of all items. Same for us. When I logged out and did the test again with an unassociated email and name the email came correct.

    I can still grant you access if you would like to test it while logged in. Or, send you my username and password so you can try it as a super users?

  • Kasia Swiderska

    Helo Bryant,

    Please enable support access (don't publish here in thread any credentials, threads are public - support access gives me super admin power) - if that subsite is not accessible without separate credentials you can leave them in support message in when you will be enabling access.

    I tested this on my site, as logged in user and I could not replicate this issue. I got one correct email as client and one correct as admin. So i would like to check your settings to see if I can replicate.

    kind regards,
    Kasia

  • Kasia Swiderska

    Hello Bryant,

    Thanks for the access - I tested with my test keys and I was able to replicate this issue this time on your site.
    However even when I tried to replicate this on my site, using very similar options like on your site I wasn't able - that second incorrect message is not send at all. I did multiple tests and could not get it.

    Would it be possible to run a quick plugin conflict test as illustrated in getting support manual (flowchart)?
    http://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    If not then lets try with debug log. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file - so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.