Marketpress that working with the MINIMAL theme! UGH!

I just paid for a new Wordpress theme, and Marketpress is NOT working again! It's causing the site to shut down and give this message: Fatal error: Cannot redeclare debugLog() (previously declared in /home/arttist/public_html/wp-content/themes/milo/inc/debug.php:4) in /home/arttist/public_html/wp-content/plugins/marketpress/includes/common/payment-gateways/_payway.php on line 473

When I deactivate Marketpress, the site works fine. How do I resolve this because I paid for this theme and I still want my clients to be able to shop! I'm frustrated because this happened before, and I had to use a theme that I didn't like for my website just so the Marketpress could work. Now that I've paid for this, I need it to work, or I'm going to have to try another ecommerce option. :0(

  • Vaughan
    • Support/SLS MockingJay

    Hi Tamara,

    Hope you're well?

    It sounds like the theme has a class inside it that is the same name as the class in our plugin.

    It's debateable whether you can put the blame on us for that, when the theme itself also uses it.

    However, to fix this I think is simple.

    I have renamed the debugLog functions and calls in the file.

    Please find the attached zip file.

    Download and unzip this to your desktop.

    Now upload the enclosed _epayway.php file

    You need to upload this file to the following location using FTP.

    /wp-content/plugins/marketpress/includes/common/payment-gateways/

    Make sure to overwrite the existing file.

    Hopefully that should fix the issue.

    Let us know if that fixes it, and i'll see if I can get these changes included in the next MP update.

    Hope this helps

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.